summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2017-02-28 20:41:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-04 23:18:10 +0000
commitf7d4375146af22c72e2bdc9426329cd37f610a47 (patch)
tree1986c1e39774b2fcf8adca6b1eee8c83a339c02c /meta/recipes-bsp
parent8e756a808267da26c5c93729438e5757146be534 (diff)
downloadopenembedded-core-contrib-f7d4375146af22c72e2bdc9426329cd37f610a47.tar.gz
u-boot: Fix handling of CMD_LICENSE in u-boot-mkimage
Only ever change the CMD_LICENSE in the u-boot config if it is enabled to prevent corruption of the config file. In case the CMD_LICENSE was already disabled, the sed substitution inserted another "# " in front of the CMD_LICENSE which triggered a restart of Kconfig oldconfig and failed the build. Signed-off-by: Marek Vasut <marex@denx.de> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
index 66edae812f..c110226710 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
@@ -13,7 +13,7 @@ do_compile () {
# Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
# generating it requires bin2header tool, which for target build
# is built with target tools and thus cannot be executed on host.
- sed -i "s/CONFIG_CMD_LICENSE.*/# CONFIG_CMD_LICENSE is not set/" .config
+ sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
oe_runmake cross_tools NO_SDL=1
}