aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-05-07 15:30:53 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-09 22:25:46 +0100
commit76c53feaec1b8c1045aaf2a78a9225a732a37f1f (patch)
tree73d5a5712ec2a97fb15a714a8e22d979ff703b20 /meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch
parent41d53f0139a9cb29679dbcaaab8311a1364c65f4 (diff)
downloadopenembedded-core-contrib-76c53feaec1b8c1045aaf2a78a9225a732a37f1f.tar.gz
bind: update libxml2 detection patch
Refresh the libxml2 detection patch to directly call pkg-config instead of attempting to use xml2-config, which will always return an error in OE. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch')
-rw-r--r--meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch b/meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch
new file mode 100644
index 0000000000..cb5251d159
--- /dev/null
+++ b/meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch
@@ -0,0 +1,42 @@
+xml2-config is disabled, so change the configure script to use pkgconfig to find
+libxml2.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+---
+ configure.in | 18 +++---------------
+ 1 file changed, 3 insertions(+), 15 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index d566e1c..c9ef3a6 100644
+--- a/configure.in
++++ b/configure.in
+@@ -2102,21 +2102,9 @@ case "$use_libxml2" in
+ DST_LIBXML2_INC=""
+ ;;
+ auto|yes)
+- case X`(xml2-config --version) 2>/dev/null` in
+- X2.[[6789]].*)
+- libxml2_libs=`xml2-config --libs`
+- libxml2_cflags=`xml2-config --cflags`
+- ;;
+- *)
+- libxml2_libs=
+- libxml2_cflags=
+- ;;
+- esac
+- ;;
+- *)
+- if test -f "$use_libxml2/bin/xml2-config" ; then
+- libxml2_libs=`$use_libxml2/bin/xml2-config --libs`
+- libxml2_cflags=`$use_libxml2/bin/xml2-config --cflags`
++ if pkg-config --exists libxml-2.0 ; then
++ libxml2_libs=`pkg-config libxml-2.0 --libs`
++ libxml2_cflags=`pkg-config libxml-2.0 --cflags`
+ fi
+ ;;
+ esac
+--
+2.1.4
+