aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/portmap/portmap_6.0.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-09-10 03:38:14 -0400
committerChen Qi <Qi.Chen@windriver.com>2014-09-14 14:47:31 +0800
commit9238ddcf23be0bed3d8e4c69d19308fda5c91e61 (patch)
treec5b06ebd19fbebb5803306c38efa3d22f0c2d3b9 /meta/recipes-connectivity/portmap/portmap_6.0.bb
parentd39086462e686eb99b330bca883d1c187f38a02b (diff)
downloadopenembedded-core-contrib-9238ddcf23be0bed3d8e4c69d19308fda5c91e61.tar.gz
portmap: add systemd service fileChenQi/portmap-systemd
Add systemd service file for systemd support. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Diffstat (limited to 'meta/recipes-connectivity/portmap/portmap_6.0.bb')
-rw-r--r--meta/recipes-connectivity/portmap/portmap_6.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/portmap/portmap_6.0.bb b/meta/recipes-connectivity/portmap/portmap_6.0.bb
index b0a9454c48..8b65a03346 100644
--- a/meta/recipes-connectivity/portmap/portmap_6.0.bb
+++ b/meta/recipes-connectivity/portmap/portmap_6.0.bb
@@ -5,7 +5,8 @@ PR = "r9"
SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.0.tgz \
file://destdir-no-strip.patch \
file://tcpd-config.patch \
- file://portmap.init"
+ file://portmap.init \
+ file://portmap.service"
SRC_URI[md5sum] = "ac108ab68bf0f34477f8317791aaf1ff"
SRC_URI[sha256sum] = "02c820d39f3e6e729d1bea3287a2d8a6c684f1006fb9612f97dcad4a281d41de"
@@ -23,4 +24,8 @@ fakeroot do_install() {
install -d ${D}${mandir}/man8/ ${D}${base_sbindir} ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/portmap.init ${D}${sysconfdir}/init.d/portmap
oe_runmake install DESTDIR=${D}
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@BASE_SBINDIR@,${base_sbindir},g' ${D}${systemd_unitdir}/system/portmap.service
}