summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-files/base-files_3.0.14.bb
diff options
context:
space:
mode:
authorPaul Gortmaker <paul.gortmaker@windriver.com>2014-07-27 22:58:36 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-29 09:56:30 +0100
commit5cba414e3fd7dbe761a6f628c6a368a412c0cba3 (patch)
tree2fd4c520c908cdb4ac81db0397b4792f993c8195 /meta/recipes-core/base-files/base-files_3.0.14.bb
parent77e4defa57f02b7f7ad23b07f169ec280228585b (diff)
downloadopenembedded-core-contrib-5cba414e3fd7dbe761a6f628c6a368a412c0cba3.tar.gz
base-files: fix up misleading dir grouping names for lsb dirs
In commit b0df35f47fb79dc149504bd66d1186b3276f9510 ("base-files: Add to make some directories needed by LSB.") there were new groupings of dirs made. But rather than keep the grouping names permissions based as they clearly were, it seems that it was unfortunately misinterpreted as a counter, simply incrementing as a new group was added. This leads to dir3755 getting chmod'd to 0755 and dir4775 being chmod'd to 2775 which to any new reader of the code is terribly confusing. Choose names that clearly reflect the permissions, and add a lsb suffix to indicate the role. Also note that the settings for /var/mail seem incorrect, and so they have been aligned with what is seen in most common distros. Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/base-files/base-files_3.0.14.bb')
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb19
1 files changed, 10 insertions, 9 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 10d0f449fa..30b1bf463b 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -45,12 +45,13 @@ dirs755 = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
${localstatedir}/volatile/log \
/home ${prefix}/src ${localstatedir}/local \
/media"
-dirs3755 = "/srv \
- ${prefix}/local ${prefix}/local/bin ${prefix}/local/games \
- ${prefix}/local/include ${prefix}/local/lib ${prefix}/local/sbin \
- ${prefix}/local/share ${prefix}/local/src \
- ${prefix}/lib/locale"
-dirs4775 = "/var/mail"
+
+dirs755-lsb = "/srv \
+ ${prefix}/local ${prefix}/local/bin ${prefix}/local/games \
+ ${prefix}/local/include ${prefix}/local/lib ${prefix}/local/sbin \
+ ${prefix}/local/share ${prefix}/local/src \
+ ${prefix}/lib/locale"
+dirs2775-lsb = "/var/mail"
volatiles = "log tmp"
conffiles = "${sysconfdir}/debian_version ${sysconfdir}/host.conf \
@@ -130,12 +131,12 @@ do_install_basefilesissue () {
}
do_install_append_linuxstdbase() {
- for d in ${dirs3755}; do
+ for d in ${dirs755-lsb}; do
install -m 0755 -d ${D}$d
done
- for d in ${dirs4775}; do
- install -m 2755 -d ${D}$d
+ for d in ${dirs2775-lsb}; do
+ install -m 2775 -d ${D}$d
done
}