aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2013-08-16 13:07:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-20 15:31:25 +0100
commit8d6559c2c59565c3e3d5f30d57cdb859a5585945 (patch)
tree5b042dad50c0d20772b05ca1f3b39aee479f96ac /meta/recipes-core/coreutils
parent6ef217defd8d10719e6d9a3f49814cf79817f3db (diff)
downloadopenembedded-core-contrib-8d6559c2c59565c3e3d5f30d57cdb859a5585945.tar.gz
coreutils: allow for acl support
CQID: 430353 Define PACKAGECONFIG info for acl assuming it might be a DISTRO_FEATURE. (From OE-Core rev: a8455a13554088613d4576a74b19294a8b49ff88) Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.21.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.21.bb b/meta/recipes-core/coreutils/coreutils_8.21.bb
index 26ada48b64..35c9100ee4 100644
--- a/meta/recipes-core/coreutils/coreutils_8.21.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.21.bb
@@ -22,8 +22,16 @@ SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
SRC_URI[md5sum] = "065ba41828644eca5dd8163446de5d64"
SRC_URI[sha256sum] = "adaa44bdab3fa5eb352e80d8a31fdbf957b78653d0c2cd30d63e161444288e18"
-EXTRA_OECONF = "--disable-acl"
-EXTRA_OECONF_class-native = "--disable-acl --without-gmp"
+EXTRA_OECONF_class-native = "--without-gmp"
+
+# acl is not a default feature
+#
+PACKAGECONFIG_class-target ??= "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+PACKAGECONFIG_class-native ??= ""
+
+# with, without, depends, rdepends
+#
+PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
# [ df mktemp base64 gets a special treatment and is not included in this
bindir_progs = "basename chcon cksum comm csplit cut dir dircolors dirname du \