summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-08-09 16:36:49 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-10 10:45:33 +0100
commit5ed0d5a7d9b051a551a6de644bf6a42b87c12471 (patch)
treed2f02911fe3de92ba1a042aa5860f5c2a35f1f5a /meta/recipes-core/dbus/dbus
parent655778769f50d3aff74d7a436d28ac31b6aebb11 (diff)
downloadopenembedded-core-contrib-5ed0d5a7d9b051a551a6de644bf6a42b87c12471.tar.gz
dbus: backport stdint.h build fix
This patch fixes an error where dbus configure doesn't detect stdint.h correctly. Upstream commit 1bfde222 on branches dbus-1.10 and master Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/dbus/dbus')
-rw-r--r--meta/recipes-core/dbus/dbus/0001-configure.ac-explicitely-check-stdint.h.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus/0001-configure.ac-explicitely-check-stdint.h.patch b/meta/recipes-core/dbus/dbus/0001-configure.ac-explicitely-check-stdint.h.patch
new file mode 100644
index 0000000000..85acb7b1ca
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus/0001-configure.ac-explicitely-check-stdint.h.patch
@@ -0,0 +1,38 @@
+From 1bfde222926be624a30a6e4b2cdc2c5064a36298 Mon Sep 17 00:00:00 2001
+From: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
+Date: Fri, 29 Jul 2016 01:19:37 +0300
+Subject: [PATCH] configure.ac: explicitely check stdint.h
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Otherwise HAVE_STDINT_H will not be defined or the var will not be
+picked up from cache so builds could fail with errors like:
+| ../../dbus-1.10.8/dbus/dbus-internals.h:239:8: error: ‘uintptr_t’ undeclared (first use in this function)
+
+Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
+[smcv: fix Autoconf underquoting]
+Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
+
+Upstream-Status: Backport [from dbus-1.10]
+
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index cf5c5b9..a228d63 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -699,6 +699,8 @@ AC_CHECK_HEADERS(byteswap.h)
+
+ AC_CHECK_HEADERS(unistd.h)
+
++AC_CHECK_HEADERS([stdint.h])
++
+ AC_CHECK_HEADERS(ws2tcpip.h)
+
+ AC_CHECK_HEADERS(alloca.h)
+--
+2.9.2
+