summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.15.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-03 10:59:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-05 10:33:18 -0800
commit41bc192c0b5795561b239872008c91a867732219 (patch)
treea21feb51bde721ba553296676ce4b5ea2662bf37 /meta/recipes-core/eglibc/eglibc_2.15.bb
parent3b57de68e70e77dbc03c0616a83a29a2e99e40b4 (diff)
downloadopenembedded-core-contrib-41bc192c0b5795561b239872008c91a867732219.tar.gz
meta: Convert getVar/getVarFlag(xxx, 1) -> (xxx, True)
Using "1" with getVar is bad coding style and "True" is preferred. This patch is a sed over the meta directory of the form: sed \ -e 's:\(\.getVar([^,()]*, \)1 *):\1True):g' \ -e 's:\(\.getVarFlag([^,()]*, [^,()]*, \)1 *):\1True):g' \ -i `grep -ril getVar *` Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.15.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.15.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.15.bb b/meta/recipes-core/eglibc/eglibc_2.15.bb
index 6d66342d59..b4c1ea5a99 100644
--- a/meta/recipes-core/eglibc/eglibc_2.15.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.15.bb
@@ -55,10 +55,10 @@ FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIR
python __anonymous () {
import bb, re
- uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', 1)) != None)
+ uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
if uc_os:
raise bb.parse.SkipPackage("incompatible with target %s" %
- d.getVar('TARGET_OS', 1))
+ d.getVar('TARGET_OS', True))
}
export libc_cv_slibdir = "${base_libdir}"