summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.16.1.bb
diff options
context:
space:
mode:
authorChristopher Larson <kergoth@gmail.com>2014-03-17 18:10:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-19 14:14:59 +0000
commitf43139adceaf8039d5347dea0a116dc5923b24c1 (patch)
treeec69d8e8f5f93e132984dfde5fe42dd26b15a786 /meta/recipes-core/gettext/gettext_0.16.1.bb
parent662ff5986370e59cf8638aab66f095f284a7238d (diff)
downloadopenembedded-core-contrib-f43139adceaf8039d5347dea0a116dc5923b24c1.tar.gz
gettext-0.16.1: kill target m4 macros from sysroot
Ever since the change to how aclocal files are copied (based on dependencies), target m4 macros seem to more reliably be used in preference to native (which they should), but in a non-gplv3 build, gettext is 0.16 while gettext-native is 0.18, causing a 0.16 po.m4 to be used with our 0.18 po/Makefile.in.in files, causing at least some failed builds, including e2fsprogs. Anyone inheriting gettext will have both gettext-native and gettext available, and we don't want to use older macros from the target gettext in a non-gplv3 build, so kill them and let dependent recipes rely on gettext-native. [YOCTO #5964] Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.16.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
index 5d26f3efdc..5725e7fe07 100644
--- a/meta/recipes-core/gettext/gettext_0.16.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.16.1.bb
@@ -95,4 +95,15 @@ do_install_append() {
rm -f ${D}${libdir}/preloadable_libintl.so
}
+# Anyone inheriting gettext will have both gettext-native and gettext
+# available, and we don't want to use older macros from the target gettext in
+# a non-gplv3 build, so kill them and let dependent recipes rely on
+# gettext-native.
+
+SYSROOT_PREPROCESS_FUNCS += "remove_sysroot_m4_macros"
+
+remove_sysroot_m4_macros () {
+ rm -r "${SYSROOT_DESTDIR}${datadir}/aclocal"
+}
+
BBCLASSEXTEND = "native nativesdk"