summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-10-08 17:17:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-14 16:54:35 +0100
commit1f03b6aa9e475f341815788613513ff63add8a5f (patch)
treef81be30c350402cea48669a4c0e169323b15e348 /meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
parentfa026cd7bf05fcc447433c1cc073b290db7d77fa (diff)
downloadopenembedded-core-contrib-1f03b6aa9e475f341815788613513ff63add8a5f.tar.gz
glib-networking: upgrade to 2.38.0 and PACKAGECONFIGise
Use PACKAGECONFIG to add options for ca-certificates, gnutls, and libproxy. Enable ca-certificates by default as all it needs to know is the right path, ca-certificates not being installed isn't fatal. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.38.0.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.38.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb b/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
new file mode 100644
index 0000000000..ad9ad64f8a
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
+HOMEPAGE = "http://git.gnome.org/browse/glib-networking/"
+BUGTRACKER = "http://bugzilla.gnome.org"
+
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SECTION = "libs"
+DEPENDS = "glib-2.0 intltool-native"
+
+GNOME_COMPRESS_TYPE = "xz"
+
+SRC_URI[archive.md5sum] = "a22907deed3d956860d83aa3233e86ff"
+SRC_URI[archive.sha256sum] = "a43eacbf721b475cf6ba0cd2eab02a332014f71a4c41d0b44bd7bbf8ed1f840d"
+
+PACKAGECONFIG ??= "ca-certificates gnutls"
+
+# No explicit dependency as it works without ca-certificates installed
+PACKAGECONFIG[ca-certificates] = "--with-ca-certificates=${sysconfdir}/ssl/certs/ca-certificates.crt,--without-ca-certificates"
+PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
+PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
+PACKAGECONFIG[pkcs11] = "--with-pkcs11,--without-pkcs11,p11-kit"
+
+EXTRA_OECONF = "--without-gnome-proxy"
+
+inherit gnomebase
+
+FILES_${PN} += "${libdir}/gio/modules/libgio*.so ${datadir}/dbus-1/services/"
+FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/"
+FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
+FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"