summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/meta-environment-extsdk.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-05 21:15:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-06 11:46:14 +0000
commit688f7a64917a5ce5cbe12f8e5da4d47e265d240f (patch)
treedec209d96fc00cc8a5fdd9ffd3f47abc167e0f4b /meta/recipes-core/meta/meta-environment-extsdk.bb
parentaf330fc0087692039d4256a6fb1e122742e8ec1a (diff)
downloadopenembedded-core-contrib-688f7a64917a5ce5cbe12f8e5da4d47e265d240f.tar.gz
meta/scripts: Various getVar/getVarFlag expansion parameter fixes
There were a few straggling expansion parameter removals left for getVar/getVarFlag where the odd whitespace meant they were missed on previous passes. There were also some plain broken ussages such as: d.getVar('ALTERNATIVE_TARGET', old_name, True) path = d.getVar('PATH', d, True) d.getVar('IMAGE_ROOTFS', 'True') which I've corrected (they happend to work by luck). Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/meta-environment-extsdk.bb')
-rw-r--r--meta/recipes-core/meta/meta-environment-extsdk.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/meta/meta-environment-extsdk.bb b/meta/recipes-core/meta/meta-environment-extsdk.bb
index 52012cc4fb..76d2661b10 100644
--- a/meta/recipes-core/meta/meta-environment-extsdk.bb
+++ b/meta/recipes-core/meta/meta-environment-extsdk.bb
@@ -6,7 +6,7 @@ PN = "meta-environment-extsdk-${MACHINE}"
create_sdk_files_append() {
local sysroot=${SDKPATH}/${@os.path.relpath(d.getVar('STAGING_DIR_TARGET'), d.getVar('TOPDIR'))}
- local sdkpathnative=${SDKPATH}/${@os.path.relpath(d.getVar('STAGING_DIR_NATIVE',True), d.getVar('TOPDIR'))}
+ local sdkpathnative=${SDKPATH}/${@os.path.relpath(d.getVar('STAGING_DIR_NATIVE'), d.getVar('TOPDIR'))}
toolchain_create_sdk_env_script '' '' $sysroot '' ${bindir_native} ${prefix_native} $sdkpathnative
}