summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-12 14:54:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-11 00:11:07 +0100
commit1e109651acd53b8bad5bc2ccdf152d747a91f1ac (patch)
tree8dba018d1e5679601b384a713836dda2efd83f58 /meta/recipes-core/musl
parentd70b9705b7997786bc95cf6e70c172470db3413c (diff)
downloadopenembedded-core-contrib-1e109651acd53b8bad5bc2ccdf152d747a91f1ac.tar.gz
musl: Update to latest on master
Bring in following changes * fix missing volatile qualifier on lock in __get_locale * remove ineffective compiler assist from printf * fix undefined behavior in ptrace * unify the use of FUTEX_PRIVATE * fix undefined behavior in free * reapply va_arg hacks removal to wprintf * remove useless declarations in string.h * allow specifying argv[0] when invoking a program via ldso command * fix regression in dlopen promotion from RTLD_LOCAL to RTLD_GLOBAL * ldso: avoid spurious & possible erroneous work for libs with no deps * powerpc64: add single-instruction math functions * fix clang CFLAGS checks and silence unused argument warnings * s390x: add single-instruction math functions * fix arm run-time abi string functions * fix regression in getspnam[_r] error code for insufficient buffer size * fix omission of microblaze user.h definitions * fix iconv conversions for iso88592-iso885916 * handle errors from localtime_r in ctime_r * set errno when getpw*_r, getgr*_r, and getspnam_r fail * handle localtime errors in ctime * handle mremap failure in realloc of mmap-serviced allocations * getdate: correctly specify error number * catopen: set errno to EOPNOTSUPP * fix glob failure to match plain "/" to root directory * use hard-coded sh4a atomic opcodes to avoid linker errors on sh Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/musl')
-rw-r--r--meta/recipes-core/musl/musl_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index fba47096f5..31583de596 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -3,7 +3,7 @@
require musl.inc
-SRCREV = "179766aa2ef06df854bc1d9616bf6f00ce49b7f9"
+SRCREV = "a08910fc2cc739f631b75b2d09b8d72a0d64d285"
PV = "1.1.16+git${SRCPV}"