summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-09-20 10:17:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-22 17:14:43 +0100
commitf15de8cf177f8f736c180c1dcaa942a9931865d4 (patch)
tree10adbc655adc1f9bb7141a6ebd3cb92cc1e9d77b /meta/recipes-core
parentb38a44e3ca30a8fe83bdccb4ee2b7748b3f7f223 (diff)
downloadopenembedded-core-contrib-f15de8cf177f8f736c180c1dcaa942a9931865d4.tar.gz
core-image-tiny-initramfs: Enable running poky-tiny on qemux86-64
Building poky-tiny for x86-64 seems fine, but when executing qemu it complains during boot time about not being able to execute init: [ 5.409730] Failed to execute /init (error -8) And then it drops to a login prompt (which it should't do on tiny) This is supposed to be complaining about init's format, it only happens on x86-64 architectures so perhaps is a 32/64 bit issue, but since core-image-tiny-initramfs does not actually provide a traditional init, the script is simply meant to drop to shell, we can workaround the issue by specifying the kernel to run the init script via busybox's sh, dropping to shell correctly on x86-64 leaving x86 unaffected. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/images/core-image-tiny-initramfs.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/images/core-image-tiny-initramfs.bb b/meta/recipes-core/images/core-image-tiny-initramfs.bb
index a8893d1e53..16995e6580 100644
--- a/meta/recipes-core/images/core-image-tiny-initramfs.bb
+++ b/meta/recipes-core/images/core-image-tiny-initramfs.bb
@@ -39,3 +39,5 @@ python tinyinitrd () {
}
IMAGE_PREPROCESS_COMMAND += "tinyinitrd;"
+
+QB_KERNEL_CMDLINE_APPEND += "debugshell=3 init=/bin/busybox sh init"