aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.148.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-29 22:27:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-02 05:47:39 -0700
commiteb44d03dfe37673de92cda6ee66f77ee6b399254 (patch)
tree6e4f25c2ca706f5b527cd922e35983b3d9dfbcd7 /meta/recipes-devtools/elfutils/elfutils_0.148.bb
parent45c4215639d2e15069c11ccb28f71580a4306dd9 (diff)
downloadopenembedded-core-contrib-eb44d03dfe37673de92cda6ee66f77ee6b399254.tar.gz
elfutils: Fix build on uclibc
It depends on libintl so add virtual/libintl to DEPENDS simplify the overridden statements Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.148.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.148.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.148.bb b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
index 90bc3081ab..5d45f3a8d2 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.148.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -4,9 +4,9 @@ SECTION = "base"
LICENSE = "(GPL-2+ & Elfutils-Exception)"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3\
file://EXCEPTION;md5=570adcb0c1218ab57f2249c67d0ce417"
-DEPENDS = "libtool bzip2 zlib"
+DEPENDS = "libtool bzip2 zlib virtual/libintl"
-PR = "r8"
+PR = "r9"
SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/elfutils-${PV}.tar.bz2"
@@ -33,7 +33,7 @@ SRC_URI += "\
file://dso-link-change.patch \
"
# Only apply when building uclibc based target recipe
-SRC_URI_append_libc-uclibc = " ${@['', 'file://uclibc-support.patch']['${PN}' == '${BPN}']}"
+SRC_URI_append_libc-uclibc = " file://uclibc-support.patch"
# The buildsystem wants to generate 2 .h files from source using a binary it just built,
# which can not pass the cross compiling, so let's work around it by adding 2 .h files
@@ -47,7 +47,7 @@ inherit autotools gettext
EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
EXTRA_OECONF_append_virtclass-native = " --without-bzlib"
-EXTRA_OECONF_append_libc-uclibc = " ${@['', '--enable-uclibc']['${PN}' == '${BPN}']}"
+EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
do_configure_prepend() {
sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am