aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl/config.sh
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-11-24 15:06:04 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:15 +0000
commitadd5e5982f010e13e3ad25690f01d5e4e391daf9 (patch)
treeea18ab41d87feedd9512010539fd5efb8d68b8b6 /meta/recipes-devtools/perl/perl/config.sh
parent0ed3cc09e3988367fa57bd08fb7db12b7fb9dabe (diff)
downloadopenembedded-core-contrib-add5e5982f010e13e3ad25690f01d5e4e391daf9.tar.gz
perl: Upgrade to 5.24.0
Configuration changes, Simple changes was made to bump version and api version, related to floating point handling now the configuration needs the inf, mantisa and nan bytes. The new version comes with the support of API calls like memmem and {new,free,use}locale also structure for handle siginfo supported by glibc and musl. Finally use64bit{int, all} was disable because the previous configure_args don't come with them and cases some tests to fail related to bignum's and shared memory respectively. This doesn't means that perl couldn't use 64-bit data types, it means that don't stores by default into a 64 bit that is good for embedded space purposes. Modules changes, Some core modules are now deprecated in order to use the core ones like version-vpp and version-regex inside module-extutils-makemaker. For full review see perl-rdepends.inc file. Patches rebased, - perl/debian/errno_ver.diff - perl/dynaloaderhack.patch - perl/Makefile.SH.patch - perl/config.s - perl/dynaloaderhack.patch - perl/perl-test-customized.patch Patches removed, comes with the upgrade now: - perl/perl-remove-nm-from-libswanted.patch - perl/perl-fix-CVE-2015-8607.patch - perl/perl-fix-CVE-2016-2381.patch Test, The upgrade was test using ptest the suite is fixed now. The pod2man and pod2text installation required now for some tests. Buildhistory was use to review the changes and only diff changes related to modules commented above. Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl/config.sh')
-rw-r--r--meta/recipes-devtools/perl/perl/config.sh94
1 files changed, 61 insertions, 33 deletions
diff --git a/meta/recipes-devtools/perl/perl/config.sh b/meta/recipes-devtools/perl/perl/config.sh
index b2a7f2cc4c..6666e6f34a 100644
--- a/meta/recipes-devtools/perl/perl/config.sh
+++ b/meta/recipes-devtools/perl/perl/config.sh
@@ -14,7 +14,7 @@
: Configure command line arguments.
config_arg0='Configure'
-config_args='-des -Doptimize=-O2 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Open Embedded -Dinstallprefix=@EXECPREFIX@ -Dprefix=@EXECPREFIX@ -Dvendorprefix=@EXECPREFIX@ -Dsiteprefix=@EXECPREFIX@ -Dotherlibdirs=@LIBDIR@/perl/5.22.1 -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Ud_dosuid -Dd_semctl_semun -Ui_db -Ui_ndbm -Ui_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly -Dpager=@USRBIN@/less -isr'
+config_args='-des -Doptimize=-O2 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Open Embedded -Dinstallprefix=@EXECPREFIX@ -Dprefix=@EXECPREFIX@ -Dvendorprefix=@EXECPREFIX@ -Dsiteprefix=@EXECPREFIX@ -Dotherlibdirs=@LIBDIR@/perl/5.24.0 -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Ud_dosuid -Dd_semctl_semun -Ui_db -Ui_ndbm -Ui_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly -Dpager=@USRBIN@/less -isr'
config_argc=28
config_arg1='-des'
config_arg2='-Doptimize=-O2'
@@ -26,7 +26,7 @@ config_arg7='-Dinstallprefix=@EXECPREFIX@'
config_arg8='-Dprefix=@EXECPREFIX@'
config_arg9='-Dvendorprefix=@EXECPREFIX@'
config_arg10='-Dsiteprefix=@EXECPREFIX@'
-config_arg11='-Dotherlibdirs=@LIBDIR@/perl/5.22.1'
+config_arg11='-Dotherlibdirs=@LIBDIR@/perl/5.24.0'
config_arg12='-Duseshrplib'
config_arg13='-Dusethreads'
config_arg14='-Duseithreads'
@@ -65,12 +65,12 @@ ansi2knr=''
aphostname=''
api_revision='5'
api_subversion='0'
-api_version='22'
-api_versionstring='5.22.0'
+api_version='24'
+api_versionstring='5.24.0'
ar='ar'
-archlib='@LIBDIR@/perl/5.22.1/@ARCH@-thread-multi'
-archlibexp='@STAGINGDIR@@LIBDIR@/perl/5.22.1/@ARCH@-thread-multi'
-archlib_exp='@LIBDIR@/perl/5.22.1/@ARCH@-thread-multi'
+archlib='@LIBDIR@/perl/5.24.0/@ARCH@-thread-multi'
+archlibexp='@STAGINGDIR@@LIBDIR@/perl/5.24.0/@ARCH@-thread-multi'
+archlib_exp='@LIBDIR@/perl/5.24.0/@ARCH@-thread-multi'
archname64=''
archname='@ARCH@-thread-multi'
archobjs=''
@@ -88,7 +88,7 @@ castflags='0'
cat='cat'
cc='gcc'
cccdlflags='-fPIC'
-ccdlflags='-Wl,-E -Wl,-rpath,@LIBDIR@/perl/5.22.1/@ARCH@-thread-multi/CORE'
+ccdlflags='-Wl,-E -Wl,-rpath,@LIBDIR@/perl/5.24.0/@ARCH@-thread-multi/CORE'
ccflags='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2'
ccflags_uselargefiles='-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
ccname='gcc'
@@ -648,11 +648,15 @@ db_version_patch=''
direntrytype='struct dirent'
dlext='so'
dlsrc='dl_dlopen.xs'
+doubleinfbytes='0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0xf0, 0x7f'
doublekind='3'
+doublemantbits='52'
+doublenanbytes='0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0xf8, 0xff'
doublesize='8'
drand01='Perl_drand48()'
drand48_r_proto='REENTRANT_PROTO_I_ST'
dtrace=''
+dtraceobject=''
dynamic_ext='B Compress/Raw/Bzip2 Compress/Raw/Zlib Cwd Data/Dumper Devel/PPPort Devel/Peek Digest/MD5 Digest/SHA Encode Fcntl File/DosGlob File/Glob Filter/Util/Call Hash/Util Hash/Util/FieldHash I18N/Langinfo IO IPC/SysV List/Util MIME/Base64 Math/BigInt/FastCalc NDBM_File ODBM_File Opcode POSIX PerlIO/encoding PerlIO/mmap PerlIO/scalar PerlIO/via SDBM_File Socket Storable Sys/Hostname Sys/Syslog Tie/Hash/NamedCapture Time/HiRes Time/Piece Unicode/Collate XS/APItest XS/Typemap arybase attributes mro re threads threads/shared'
eagain='EAGAIN'
ebcdic='undef'
@@ -834,7 +838,7 @@ inc_version_list_init='0'
incpath=''
inews=''
initialinstalllocation='@USRBIN@'
-installarchlib='@LIBDIR@/perl/5.22.1/@ARCH@-thread-multi'
+installarchlib='@LIBDIR@/perl/5.24.0/@ARCH@-thread-multi'
installbin='@USRBIN@'
installhtml1dir=''
installhtml3dir=''
@@ -842,23 +846,23 @@ installman1dir=''
installman3dir=''
installprefix='@EXECPREFIX@'
installprefixexp='@EXECPREFIX@'
-installprivlib='@LIBDIR@/perl/5.22.1'
+installprivlib='@LIBDIR@/perl/5.24.0'
installscript='@USRBIN@'
-installsitearch='@LIBDIR@/perl/site_perl/5.22.1/@ARCH@-thread-multi'
+installsitearch='@LIBDIR@/perl/site_perl/5.24.0/@ARCH@-thread-multi'
installsitebin='@USRBIN@'
installsitehtml1dir=''
installsitehtml3dir=''
-installsitelib='@LIBDIR@/perl/site_perl/5.22.1'
+installsitelib='@LIBDIR@/perl/site_perl/5.24.0'
installsiteman1dir=''
installsiteman3dir=''
installsitescript='@USRBIN@'
installstyle='lib/perl'
installusrbinperl='define'
-installvendorarch='@LIBDIR@/perl/vendor_perl/5.22.1/@ARCH@-thread-multi'
+installvendorarch='@LIBDIR@/perl/vendor_perl/5.24.0/@ARCH@-thread-multi'
installvendorbin='@USRBIN@'
installvendorhtml1dir=''
installvendorhtml3dir=''
-installvendorlib='@LIBDIR@/perl/vendor_perl/5.22.1'
+installvendorlib='@LIBDIR@/perl/vendor_perl/5.24.0'
installvendorman1dir=''
installvendorman3dir=''
installvendorscript='@USRBIN@'
@@ -895,7 +899,10 @@ lns='/bin/ln -s'
localtime_r_proto='REENTRANT_PROTO_S_TS'
locincpth='@EXECPREFIX@/local/include /opt/local/include @EXECPREFIX@/gnu/include /opt/gnu/include @EXECPREFIX@/GNU/include /opt/GNU/include'
loclibpth='@EXECPREFIX@/local@BASELIBDIR@ /opt/local@BASELIBDIR@ @EXECPREFIX@/gnu@BASELIBDIR@ /opt/gnu@BASELIBDIR@ @EXECPREFIX@/GNU@BASELIBDIR@ /opt/GNU@BASELIBDIR@'
+longdblinfbytes='0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x80, 0xff, 0x7f, 0x00, 0x00'
longdblkind='3'
+longdblmantbits='64'
+longdblnanbytes='0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0xc0, 0xff, 0xff, 0x32, 0xf7'
longdblsize='16'
longlongsize='8'
longsize='8'
@@ -948,6 +955,7 @@ nv_preserves_uv_bits='53'
nveformat='"e"'
nvfformat='"f"'
nvgformat='"g"'
+nvmantbits='52'
nvsize='8'
nvtype='double'
o_nonblock='O_NONBLOCK'
@@ -957,11 +965,11 @@ optimize='-O2'
orderlib='false'
osname='linux'
osvers='3.19.5-yocto-standard'
-otherlibdirs='@LIBDIR@/perl/5.22.1'
+otherlibdirs='@LIBDIR@/perl/5.24.0'
package='perl'
pager='/usr/bin/less -isr'
passcat='cat /etc/passwd'
-patchlevel='22'
+patchlevel='24'
path_sep=':'
perl5='@USRBIN@/perl'
perl='perl'
@@ -978,8 +986,8 @@ pmake=''
pr=''
prefix='@EXECPREFIX@'
prefixexp='@EXECPREFIX@'
-privlib='@LIBDIR@/perl/5.22.1'
-privlibexp='@LIBDIR@/perl/5.22.1'
+privlib='@LIBDIR@/perl/5.24.0'
+privlibexp='@LIBDIR@/perl/5.24.0'
procselfexe='"/proc/self/exe"'
prototype='define'
ptrsize='8'
@@ -1045,17 +1053,17 @@ sig_num='0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
sig_num_init='0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 6, 17, 29, 31, 0'
sig_size='69'
signal_t='void'
-sitearch='@LIBDIR@/perl/site_perl/5.22.1/@ARCH@-thread-multi'
-sitearchexp='@LIBDIR@/perl/site_perl/5.22.1/@ARCH@-thread-multi'
+sitearch='@LIBDIR@/perl/site_perl/5.24.0/@ARCH@-thread-multi'
+sitearchexp='@LIBDIR@/perl/site_perl/5.24.0/@ARCH@-thread-multi'
sitebin='@USRBIN@'
sitebinexp='@USRBIN@'
sitehtml1dir=''
sitehtml1direxp=''
sitehtml3dir=''
sitehtml3direxp=''
-sitelib='@LIBDIR@/perl/site_perl/5.22.1'
+sitelib='@LIBDIR@/perl/site_perl/5.24.0'
sitelib_stem='@LIBDIR@/perl/site_perl'
-sitelibexp='@LIBDIR@/perl/site_perl/5.22.1'
+sitelibexp='@LIBDIR@/perl/site_perl/5.24.0'
siteman1dir=''
siteman1direxp=''
siteman3dir=''
@@ -1134,8 +1142,8 @@ uname='uname'
uniq='uniq'
uquadtype='unsigned long'
use5005threads='undef'
-use64bitall='define'
-use64bitint='define'
+use64bitall='undef'
+use64bitint='undef'
usecbacktrace='undef'
usecrosscompile='define'
usedevel='undef'
@@ -1174,17 +1182,17 @@ uvtype='unsigned long'
uvuformat='"lu"'
uvxformat='"lx"'
vaproto='define'
-vendorarch='@LIBDIR@/perl/vendor_perl/5.22.1/@ARCH@-thread-multi'
-vendorarchexp='@LIBDIR@/perl/vendor_perl/5.22.1/@ARCH@-thread-multi'
+vendorarch='@LIBDIR@/perl/vendor_perl/5.24.0/@ARCH@-thread-multi'
+vendorarchexp='@LIBDIR@/perl/vendor_perl/5.24.0/@ARCH@-thread-multi'
vendorbin='@USRBIN@'
vendorbinexp='@USRBIN@'
vendorhtml1dir=' '
vendorhtml1direxp=''
vendorhtml3dir=' '
vendorhtml3direxp=''
-vendorlib='@LIBDIR@/perl/vendor_perl/5.22.1'
+vendorlib='@LIBDIR@/perl/vendor_perl/5.24.0'
vendorlib_stem='@LIBDIR@/perl/vendor_perl'
-vendorlibexp='@LIBDIR@/perl/vendor_perl/5.22.1'
+vendorlibexp='@LIBDIR@/perl/vendor_perl/5.24.0'
vendorman1dir=' '
vendorman1direxp=''
vendorman3dir=' '
@@ -1193,8 +1201,8 @@ vendorprefix='@EXECPREFIX@'
vendorprefixexp='@EXECPREFIX@'
vendorscript='@USRBIN@'
vendorscriptexp='@USRBIN@'
-version='5.22.1'
-version_patchlevel_string='version 22 subversion 1'
+version='5.24.0'
+version_patchlevel_string='version 24 subversion 0'
versiononly='undef'
vi=''
xlibpth='@LIBDIR@/386 @BASELIBDIR@386'
@@ -1203,10 +1211,10 @@ yaccflags=''
zcat=''
zip='zip'
PERL_REVISION=5
-PERL_VERSION=22
-PERL_SUBVERSION=1
+PERL_VERSION=24
+PERL_SUBVERSION=0
PERL_API_REVISION=5
-PERL_API_VERSION=22
+PERL_API_VERSION=24
PERL_API_SUBVERSION=0
PERL_PATCHLEVEL=''
PERL_CONFIG_SH=true
@@ -1219,3 +1227,23 @@ d_clock_gettime='define'
d_clock_getres='define'
d_clock='define'
d_nanosleep='define'
+
+# for Signinfo
+d_siginfo_si_errno='define'
+d_siginfo_si_pid='define'
+d_siginfo_si_uid='define'
+d_siginfo_si_addr='define'
+d_siginfo_si_status='define'
+d_siginfo_si_band='define'
+d_siginfo_si_value='define'
+
+# don't support fdclose
+d_fdclose='undef'
+
+# support memmem
+d_memmem='define'
+
+# for locale
+d_newlocale='define'
+d_freelocale='define'
+d_uselocale='define'