aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.3.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-03-01 17:58:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-01 13:00:58 +0000
commit643cdac63353527c1b5cb6eeabe75df8d0dc8346 (patch)
tree1ef173da2219f1512e1ddd275d7842c721aa2fbd /meta/recipes-devtools/perl/perl_5.14.3.bb
parent365aa1412a3d31128cb3df02959acdc7df5f2ebc (diff)
downloadopenembedded-core-contrib-643cdac63353527c1b5cb6eeabe75df8d0dc8346.tar.gz
perl-nativesdk:fix toolchain relocation issues
1, Use create_wrapper to create perl wrapper in the SDK. 2, Add perl.real to perl-nativesdk package. [YOCTO #3338] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.3.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.3.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.3.bb b/meta/recipes-devtools/perl/perl_5.14.3.bb
index 6a3a170126..1c3566b484 100644
--- a/meta/recipes-devtools/perl/perl_5.14.3.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.3.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r0"
+PR = "r1"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -210,6 +210,11 @@ do_install() {
}
+do_install_append_class-nativesdk () {
+ create_wrapper ${D}${bindir}/perl \
+ PERL5LIB='$PERL5LIB:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl/${PV}'
+}
+
PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"
perl_package_preprocess () {
@@ -247,6 +252,7 @@ FILES_${PN} = "${bindir}/perl ${bindir}/perl${PV} \
${libdir}/perl/${PV}/warnings \
${libdir}/perl/${PV}/vars.pm \
"
+FILES_${PN}_append_class-nativesdk = " ${bindir}/perl.real"
RPROVIDES_${PN} += "perl-module-strict perl-module-vars perl-module-config perl-module-warnings \
perl-module-warnings-register"
FILES_${PN}-dev = "${libdir}/perl/${PV}/CORE"