summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-scons-native_3.1.2.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-02-24 20:21:42 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-28 23:08:11 +0000
commit44b46ae6c65448901477def57a45d5a4ecc2d246 (patch)
tree5f70e4c1a9de94a9545043ddd8ce6932622d5f43 /meta/recipes-devtools/python/python3-scons-native_3.1.2.bb
parentc616731ed90f5b20ae9d59165140ecd242cf44b2 (diff)
downloadopenembedded-core-contrib-44b46ae6c65448901477def57a45d5a4ecc2d246.tar.gz
python3-scons{-native}: upgrade 3.1.1 -> 3.1.2
THis release is a mix of improvements and fixes: https://github.com/SCons/scons/blob/3.1.2/src/RELEASE.txt * Changed to inherit pypi rather than relying on SOURCEFORGE_MIRROR. * Add SRC_URI for LICENSE file (not included in pypi tarball). * Make it more obvious that RDEPENDS are for class-target and drop empty RDEPENDS from -native * python3-scons-native now DEPENDS on python3-setuptools-native * Tested with core-image-base + packagegroup-core-buildessential with "scons" oe-selftest via testimage. * Tested build of "serf" (which uses python3-scons-native via the scons.bbclass). License-Update: Added "MIT License" text, updated copyright years Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-scons-native_3.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-scons-native_3.1.2.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-scons-native_3.1.2.bb b/meta/recipes-devtools/python/python3-scons-native_3.1.2.bb
new file mode 100644
index 0000000000..9e127304d6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-scons-native_3.1.2.bb
@@ -0,0 +1,7 @@
+require python3-scons_${PV}.bb
+inherit native python3native
+DEPENDS = "python3-native python3-setuptools-native"
+
+do_install_append() {
+ create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1'
+}