aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-27 08:57:14 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-28 15:11:11 +0100
commit5cf12b20c08d927af8b1a4e2997d325a030c2269 (patch)
tree652d43465f34eb435ecd54d682c0bac820f3f3a1 /meta/recipes-devtools/python
parentbd96d929345e90d121f7a5d40fde382a4f83796b (diff)
downloadopenembedded-core-contrib-5cf12b20c08d927af8b1a4e2997d325a030c2269.tar.gz
python3-distribute: fix interpreter
It should use "/usr/bin/env python3" rather than python. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-distribute_0.6.32.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-distribute_0.6.32.bb b/meta/recipes-devtools/python/python3-distribute_0.6.32.bb
index 573096cb1c..0ef3a8762f 100644
--- a/meta/recipes-devtools/python/python3-distribute_0.6.32.bb
+++ b/meta/recipes-devtools/python/python3-distribute_0.6.32.bb
@@ -37,6 +37,8 @@ do_install_append() {
rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
+ sed -i -e '1s|^#!.*python|#!/usr/bin/env python3|' \
+ ${D}${PYTHON_SITEPACKAGES_DIR}/distribute-${PV}-py${PYTHON_BASEVERSION}.egg/setuptools/tests/test_resources.py
}
RDEPENDS_${PN} = "\