aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-22 17:43:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-31 10:21:04 -0700
commit81813c0e322dc04ce4b069117188d8a54dfddb8c (patch)
tree3363bac6dcdcdad14ba58efcea39529436cdf72d /meta/recipes-devtools/qemu
parentf01f0b8aed25af889f48fe1afff96feb3d9ed120 (diff)
downloadopenembedded-core-contrib-81813c0e322dc04ce4b069117188d8a54dfddb8c.tar.gz
nativesdk: Switch to using nativesdk as a prefix, not a suffix
As discussed on the mailing lists, using a suffix to package names is hard and has lead to many recipes having to do PKGSUFFIX games. Its looking extremely hard to scale nativesdk much further without hacking many recipes. By comparison, using a prefix like multilib does works much better and doesn't involve "hacking" as many recipes. This change converts nativesdk to use a prefix using the existing multilib infrastructure. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb (renamed from meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb)2
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
index df0cae068e..fbf9e771df 100644
--- a/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
+++ b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
@@ -1,7 +1,7 @@
SUMMARY = "Qemu helper scripts"
DESCRIPTION = "Qemu helper scripts"
LICENSE = "GPLv2"
-RDEPENDS_${PN} = "qemu-nativesdk"
+RDEPENDS_${PN} = "nativesdk-qemu"
PR = "r9"
FILESPATH = "${FILE_DIRNAME}/qemu-helper"
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index 9cb4aee458..bdb566d88f 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -22,7 +22,7 @@ inherit autotools
do_configure() {
# Handle distros such as CentOS 5 32-bit that do not have kvm support
KVMOPTS="--disable-kvm"
- if [ "${PN}" != "qemu-native" -a "${PN}" != "qemu-nativesdk" ] \
+ if [ "${PN}" != "qemu-native" -a "${PN}" != "nativesdk-qemu" ] \
|| [ -f /usr/include/linux/kvm.h ] ; then
KVMOPTS="--enable-kvm"
fi
@@ -41,8 +41,8 @@ do_install () {
PACKAGECONFIG ??= ""
DEPENDS_virtclass-native = "zlib-native alsa-lib-native glib-2.0-native"
-DEPENDS_virtclass-nativesdk = "zlib-nativesdk libsdl-nativesdk glib-2.0-nativesdk"
-RDEPENDS_virtclass-nativesdk = "libsdl-nativesdk"
+DEPENDS_virtclass-nativesdk = "nativesdk-zlib nativesdk-libsdl nativesdk-glib-2.0"
+RDEPENDS_virtclass-nativesdk = "nativesdk-libsdl"
EXTRA_OECONF_virtclass-nativesdk = "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls \
--disable-curl \
"