aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-10-17 09:51:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-18 12:03:29 +0100
commit945c8f5c687ec61c312209e075edc402f6272186 (patch)
treee9b69171cb827d6f1fa4718920be53a7661a4030 /meta/recipes-devtools/qemu
parent10d28438c1e7d793bc398a0ad484782e5baa4877 (diff)
downloadopenembedded-core-contrib-945c8f5c687ec61c312209e075edc402f6272186.tar.gz
qemu: don't ignore libexecdir in configure
This allow the relocation of libexecdir to be done correctly for the qemu-brigde-helper. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemu-1.2.0/remove-hardcoded-libexec.patch41
-rw-r--r--meta/recipes-devtools/qemu/qemu-git/remove-hardcoded-libexec.patch41
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.2.0.bb3
3 files changed, 84 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-1.2.0/remove-hardcoded-libexec.patch b/meta/recipes-devtools/qemu/qemu-1.2.0/remove-hardcoded-libexec.patch
new file mode 100644
index 0000000000..8db460a5f6
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-1.2.0/remove-hardcoded-libexec.patch
@@ -0,0 +1,41 @@
+This will allow the libexecdir to be set on the command line
+and have the files installed and used from the correct location
+
+Upstream-Status: Inappropriate [oe-core specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: qemu-1.2.0/configure
+===================================================================
+--- qemu-1.2.0.orig/configure
++++ qemu-1.2.0/configure
+@@ -183,6 +183,7 @@ datadir="\${prefix}/share"
+ qemu_docdir="\${prefix}/share/doc/qemu"
+ bindir="\${prefix}/bin"
+ libdir="\${prefix}/lib"
++libexecdir="\${prefix}/libexec"
+ includedir="\${prefix}/include"
+ sysconfdir="\${prefix}/etc"
+ confsuffix="/qemu"
+@@ -644,7 +645,9 @@ for opt do
+ ;;
+ --sysconfdir=*) sysconfdir="$optarg"
+ ;;
+- --sbindir=*|--libexecdir=*|--sharedstatedir=*|--localstatedir=*|\
++ --libexecdir=*) libexecdir="$optarg"
++ ;;
++ --sbindir=*|--sharedstatedir=*|--localstatedir=*|\
+ --oldincludedir=*|--datarootdir=*|--infodir=*|--localedir=*|\
+ --htmldir=*|--dvidir=*|--pdfdir=*|--psdir=*)
+ # These switches are silently ignored, for compatibility with
+@@ -3190,8 +3193,8 @@ echo "sysconfdir=$sysconfdir" >> $config
+ echo "qemu_confdir=$qemu_confdir" >> $config_host_mak
+ echo "qemu_datadir=$qemu_datadir" >> $config_host_mak
+ echo "qemu_docdir=$qemu_docdir" >> $config_host_mak
+-echo "libexecdir=\${prefix}/libexec" >> $config_host_mak
+-echo "CONFIG_QEMU_HELPERDIR=\"$prefix/libexec\"" >> $config_host_mak
++echo "libexecdir=$libexecdir" >> $config_host_mak
++echo "CONFIG_QEMU_HELPERDIR=\"$libexecdir\"" >> $config_host_mak
+
+ echo "ARCH=$ARCH" >> $config_host_mak
+ if test "$debug_tcg" = "yes" ; then
diff --git a/meta/recipes-devtools/qemu/qemu-git/remove-hardcoded-libexec.patch b/meta/recipes-devtools/qemu/qemu-git/remove-hardcoded-libexec.patch
new file mode 100644
index 0000000000..83f5463aad
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-git/remove-hardcoded-libexec.patch
@@ -0,0 +1,41 @@
+This will allow the libexecdir to be set on the command line
+and have the files installed and used from the correct location
+
+Upstream-Status: Inappropriate [oe-core specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: qemu-1.2.0/configure
+===================================================================
+--- qemu-1.2.0.orig/configure
++++ qemu-1.2.0/configure
+@@ -183,6 +183,7 @@ datadir="\${prefix}/share"
+ qemu_docdir="\${prefix}/share/doc/qemu"
+ bindir="\${prefix}/bin"
+ libdir="\${prefix}/lib"
++libexecdir="\${prefix}/libexec"
+ includedir="\${prefix}/include"
+ sysconfdir="\${prefix}/etc"
+ confsuffix="/qemu"
+@@ -644,7 +645,9 @@ for opt do
+ ;;
+ --sysconfdir=*) sysconfdir="$optarg"
+ ;;
+- --sbindir=*|--libexecdir=*|--sharedstatedir=*|--localstatedir=*|\
++ --libexecdir=*) libexecdir="$optarg"
++ ;;
++ --sbindir=*|--sharedstatedir=*|--localstatedir=*|\
+ --oldincludedir=*|--datarootdir=*|--infodir=*|--localedir=*|\
+ --htmldir=*|--dvidir=*|--pdfdir=*|--psdir=*)
+ # These switches are silently ignored, for compatibility with
+@@ -3190,8 +3193,8 @@ echo "sysconfdir=$sysconfdir" >> $config
+ echo "qemu_confdir=$qemu_confdir" >> $config_host_mak
+ echo "qemu_datadir=$qemu_datadir" >> $config_host_mak
+ echo "qemu_docdir=$qemu_docdir" >> $config_host_mak
+-echo "libexecdir=\${prefix}/libexec" >> $config_host_mak
+-echo "CONFIG_QEMU_HELPERDIR=\"$prefix/libexec\"" >> $config_host_mak
++echo "libexecdir=$libexecdir" >> $config_host_mak
++echo "CONFIG_QEMU_HELPERDIR=$libexecdir" >> $config_host_mak
+
+ echo "ARCH=$ARCH" >> $config_host_mak
+ if test "$debug_tcg" = "yes" ; then
diff --git a/meta/recipes-devtools/qemu/qemu_1.2.0.bb b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
index 517a74b05e..5cc142a624 100644
--- a/meta/recipes-devtools/qemu/qemu_1.2.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
@@ -13,11 +13,12 @@ SRC_URI = "\
file://fallback-to-safe-mmap_min_addr.patch \
file://larger_default_ram_size.patch \
file://arm-bgr.patch \
+ file://remove-hardcoded-libexec.patch \
"
SRC_URI[md5sum] = "78eb1e984f4532aa9f2bdd3c127b5b61"
SRC_URI[sha256sum] = "c8b84420d9f4869397f84cad2dabd9a475b7723d619a924a873740353e9df936"
-PR = "r3"
+PR = "r4"
SRC_URI_append_virtclass-nativesdk = "\
file://relocatable_sdk.patch \