aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-08 09:21:46 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-08 09:21:52 +0100
commit9ec1c06915b10d142bf5646396c4e91bb61a40a5 (patch)
treee6934579871e27d0f4e917af9bf39328d5c9589f /meta/recipes-devtools/qemu
parentcf25f211ec420e1e8dd48c8e62f60deefe2c6d53 (diff)
downloadopenembedded-core-contrib-9ec1c06915b10d142bf5646396c4e91bb61a40a5.tar.gz
qemu: When applying qemu-mips workaround, check the file exists first
If qemu-mips was disabled as done in some distros, this wrapper would fail. Therefore check if the file exists before wrapping it. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.2.0.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_1.2.0.bb b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
index cbdb4d472b..517a74b05e 100644
--- a/meta/recipes-devtools/qemu/qemu_1.2.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
@@ -37,8 +37,10 @@ do_configure_prepend_virtclass-nativesdk() {
# the qemu-mips works fine.
# IMPORTANT: This piece needs to be removed once the root cause is fixed!
do_install_append() {
- create_wrapper ${D}/${bindir}/qemu-mips \
- QEMU_RESERVED_VA=0x0
+ if [ -e "${D}/${bindir}/qemu-mips" ]; then
+ create_wrapper ${D}/${bindir}/qemu-mips \
+ QEMU_RESERVED_VA=0x0
+ fi
}
# END of qemu-mips workaround