aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2012-08-08 13:35:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-15 14:25:49 +0100
commita2a47ebfc3c8afa93bbf28e4a243538ea61079ac (patch)
treeceb28013e866c5c4a4a531e09d26afc917357263 /meta/recipes-devtools/qemu
parent1037c80f63922ffdec54b0eade80ec0e89062b22 (diff)
downloadopenembedded-core-contrib-a2a47ebfc3c8afa93bbf28e4a243538ea61079ac.tar.gz
qemu: backport patch to fix pl031 RTC
Intergrate the patch from: http://repo.or.cz/w/qemu.git/commit/13a16f1d91fc7a46b65b22a33f6ffea1b826a097 Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemu-0.15.1/hw-pl031-Actually-raise-interrupt-on-timer-expiry.patch41
-rw-r--r--meta/recipes-devtools/qemu/qemu_0.15.1.bb1
2 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-0.15.1/hw-pl031-Actually-raise-interrupt-on-timer-expiry.patch b/meta/recipes-devtools/qemu/qemu-0.15.1/hw-pl031-Actually-raise-interrupt-on-timer-expiry.patch
new file mode 100644
index 0000000000..2ccc663d75
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-0.15.1/hw-pl031-Actually-raise-interrupt-on-timer-expiry.patch
@@ -0,0 +1,41 @@
+Upstream-Status: Backport
+commit 13a16f1d91fc7a46b65b22a33f6ffea1b826a097
+in git://git.qemu.org/qemu.git master
+
+From 13a16f1d91fc7a46b65b22a33f6ffea1b826a097 Mon Sep 17 00:00:00 2001
+From: Peter Maydell <peter.maydell@linaro.org>
+Date: Thu, 16 Feb 2012 09:56:10 +0000
+Subject: [PATCH] hw/pl031: Actually raise interrupt on timer expiry
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fix a typo in pl031_interrupt() which meant we were setting a bit
+in the interrupt mask rather than the interrupt status register
+and thus not actually raising an interrupt. This fix allows the
+rtctest program from the kernel's Documentation/rtc.txt to pass
+rather than hanging.
+
+Reported-by: Daniel Forsgren <daniel.forsgren@enea.com>
+Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
+Acked-by: Andreas Färber <afaerber@suse.de>
+---
+ hw/pl031.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/hw/pl031.c b/hw/pl031.c
+index 05b5b11..69abc4f 100644
+--- a/hw/pl031.c
++++ b/hw/pl031.c
+@@ -76,7 +76,7 @@ static void pl031_interrupt(void * opaque)
+ {
+ pl031_state *s = (pl031_state *)opaque;
+
+- s->im = 1;
++ s->is = 1;
+ DPRINTF("Alarm raised\n");
+ pl031_update(s);
+ }
+--
+1.7.4.1
+
diff --git a/meta/recipes-devtools/qemu/qemu_0.15.1.bb b/meta/recipes-devtools/qemu/qemu_0.15.1.bb
index 7b862ed0dd..a914bcfad4 100644
--- a/meta/recipes-devtools/qemu/qemu_0.15.1.bb
+++ b/meta/recipes-devtools/qemu/qemu_0.15.1.bb
@@ -22,6 +22,7 @@ SRC_URI = "\
file://dummy-gl-config.patch \
file://0001-ppc64-Fix-linker-script.patch \
file://ppc-s500-set-invalid-mask.patch \
+ file://hw-pl031-Actually-raise-interrupt-on-timer-expiry.patch \
"
# Only use the GL passthrough patches for native/nativesdk versions