aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-10-27 16:48:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:30 +0000
commitbb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2 (patch)
treea5cd401b043e80311db7497dec8c791b873aab2e /meta/recipes-devtools/qemu
parent528b4ab831c7b0bc1412318d29e2b7f9cf711d57 (diff)
downloadopenembedded-core-contrib-bb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2.tar.gz
recipes-devtools: replace virtclass-native(sdk) with class-native(sdk)
The overrides virtclass-native and virtclass-nativesdk are deprecated, which should be replaced by class-native and class-nativesdk. [YOCTO #3297] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc12
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.2.0.bb6
2 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index 28ff76089d..95556ba8f7 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -9,8 +9,8 @@ QEMU_TARGETS ?= "arm i386 mips mipsel mips64 mips64el ppc sh4 x86_64"
require qemu-targets.inc
SDL ?= "--disable-sdl"
-SDL_virtclass-native ?= ""
-SDL_virtclass-nativesdk ?= ""
+SDL_class-native ?= ""
+SDL_class-nativesdk ?= ""
EXTRA_OECONF += "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls --audio-drv-list=oss,alsa --audio-card-list=ac97,es1370 ${SDL} --disable-curl --disable-vnc-jpeg --disable-bluez"
@@ -40,10 +40,10 @@ do_install () {
PACKAGECONFIG ??= ""
-DEPENDS_virtclass-native = "zlib-native alsa-lib-native glib-2.0-native"
-DEPENDS_virtclass-nativesdk = "nativesdk-zlib nativesdk-libsdl nativesdk-glib-2.0"
-RDEPENDS_virtclass-nativesdk = "nativesdk-libsdl"
-EXTRA_OECONF_virtclass-nativesdk = "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls \
+DEPENDS_class-native = "zlib-native alsa-lib-native glib-2.0-native"
+DEPENDS_class-nativesdk = "nativesdk-zlib nativesdk-libsdl nativesdk-glib-2.0"
+RDEPENDS_class-nativesdk = "nativesdk-libsdl"
+EXTRA_OECONF_class-nativesdk = "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls \
--disable-curl \
"
diff --git a/meta/recipes-devtools/qemu/qemu_1.2.0.bb b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
index 5cc142a624..af5eb0349c 100644
--- a/meta/recipes-devtools/qemu/qemu_1.2.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
@@ -20,11 +20,11 @@ SRC_URI[sha256sum] = "c8b84420d9f4869397f84cad2dabd9a475b7723d619a924a873740353e
PR = "r4"
-SRC_URI_append_virtclass-nativesdk = "\
+SRC_URI_append_class-nativesdk = "\
file://relocatable_sdk.patch \
"
-do_configure_prepend_virtclass-nativesdk() {
+do_configure_prepend_class-nativesdk() {
if [ "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "" ] ; then
# Undo the -lX11 added by linker-flags.patch
sed -i 's/-lX11//g' Makefile.target
@@ -45,7 +45,7 @@ do_install_append() {
}
# END of qemu-mips workaround
-do_configure_prepend_virtclass-native() {
+do_configure_prepend_class-native() {
# Undo the -lX11 added by linker-flags.patch, don't assume that host has libX11 installed
sed -i 's/-lX11//g' Makefile.target
}