aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-01-31 10:04:57 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 09:35:02 +0000
commitfaaa5e7fd4353b73289f163d9f601cf0869698f3 (patch)
tree06b3442df6a34eef2495dd51116e515910b6f2a0 /meta/recipes-devtools/qemu
parent0c12f7fb3c2c42e5b633682bb1277b943ac19ea6 (diff)
downloadopenembedded-core-contrib-faaa5e7fd4353b73289f163d9f601cf0869698f3.tar.gz
add qemuwrapper-cross recipe
This will just install a wrapper script in STAGING_BINDIR_CROSS that will execute the proper qemu user binary for the current target. [YOCTO #2599] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb b/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
new file mode 100644
index 0000000000..dc16047451
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Qemu wrapper script"
+LICENSE = "MIT"
+PR = "r0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit qemu
+
+do_install () {
+ install -d ${STAGING_BINDIR_CROSS}
+
+ echo "#!/bin/sh" > ${STAGING_BINDIR_CROSS}/qemuwrapper
+ echo exec env ${@qemu_target_binary(d)} \"\$@\" >> ${STAGING_BINDIR_CROSS}/qemuwrapper
+ chmod +x ${STAGING_BINDIR_CROSS}/qemuwrapper
+}