aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKlauer, Daniel <Daniel.Klauer@gin.de>2016-05-17 12:55:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-19 09:05:18 +0100
commite89c6c4aa682b2cba8c1c50098c95b70ad6746fc (patch)
tree91abf26a6bccd72cfba01aaf176934e1c9543377 /meta/recipes-devtools
parent350d939d4e235d54830850188a5addad6d3bd2e3 (diff)
downloadopenembedded-core-contrib-e89c6c4aa682b2cba8c1c50098c95b70ad6746fc.tar.gz
python-smartpm: Fix channel command --remove-all option (again)
SmartPM's --remove-all option was unusable, because the fix from commit 03266e89a6 was lost in commit 5fc580fc44. Thus, add a new patch to fix --remove-all. It seems like the previous fix was lost by mistake: Upstream merged the *old* version of the patch (smartpm 406541f569), and when SmartPM in oe-core was upgraded to the new upstream release, the --remove-all fix from the *new* patch was not carried over. (From OE-Core rev: ba2adda60dd34b6a8feba413e3207dd8e4580294) Signed-off-by: Daniel Klauer <daniel.klauer@gin.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-channel-remove-all.patch33
-rw-r--r--meta/recipes-devtools/python/python-smartpm_git.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-channel-remove-all.patch b/meta/recipes-devtools/python/python-smartpm/smart-channel-remove-all.patch
new file mode 100644
index 0000000000..da23e7ce42
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-channel-remove-all.patch
@@ -0,0 +1,33 @@
+From 6d2363a705697f615d9e5af5d6703b291e618b46 Mon Sep 17 00:00:00 2001
+From: Daniel Klauer <daniel.klauer@gin.de>
+Date: Thu, 12 May 2016 17:55:01 +0200
+Subject: [PATCH] Fix channel command --remove-all option parsing
+
+Option.take_action() stores a list of options given for validation later.
+It strips leading dashes and turns remaining dashes into underscores.
+This list is what ensure_action() will compare its arguments against,
+thus we must use underscores here.
+
+Upstream-Status: Pending
+
+Signed-off-by: Daniel Klauer <daniel.klauer@gin.de>
+---
+ smart/commands/channel.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/smart/commands/channel.py b/smart/commands/channel.py
+index 108f3f1..6234f69 100644
+--- a/smart/commands/channel.py
++++ b/smart/commands/channel.py
+@@ -164,7 +164,7 @@ def main(ctrl, opts):
+ opts.check_args_of_option("edit", 0)
+ opts.check_args_of_option("enable", -1)
+ opts.check_args_of_option("disable", -1)
+- opts.ensure_action("channel", ["add", "set", "remove", "remove-all",
++ opts.ensure_action("channel", ["add", "set", "remove", "remove_all",
+ "list", "show", "yaml", "enable", "disable"])
+ opts.check_remaining_args()
+
+--
+1.9.1
+
diff --git a/meta/recipes-devtools/python/python-smartpm_git.bb b/meta/recipes-devtools/python/python-smartpm_git.bb
index d9a908db2e..f030b3eb37 100644
--- a/meta/recipes-devtools/python/python-smartpm_git.bb
+++ b/meta/recipes-devtools/python/python-smartpm_git.bb
@@ -23,6 +23,7 @@ SRC_URI = "\
file://smart-already-installed-message.patch \
file://smart-set-noprogress-for-pycurl.patch \
file://smart-cache.py-getPackages-matches-name-version.patch \
+ file://smart-channel-remove-all.patch \
"
SRCREV = "407a7eca766431257dcd1da15175cc36a1bb22d0"