aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2015-04-08 15:47:56 +1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-15 18:12:03 +0100
commit9f7b0133b63d315703d0c44e877ae81d4a9a1692 (patch)
tree148487f281299f642c39aedad0a55bb4276d34bc /meta/recipes-devtools
parentcecac1d52143e34b6e1142e38a1c874188dd74e9 (diff)
downloadopenembedded-core-contrib-9f7b0133b63d315703d0c44e877ae81d4a9a1692.tar.gz
python: Change python 2.7.9 to use libffi from the system
Changes in python 2.7.9 from 2.7.3 cause issues when building the in tree libffi for ctypes. These issues primarily affect less common platforms (e.g. MicroBlaze) that are supported by libffi but the python overrides for the in tree libffi are not able to detect correctly. This patch changes the python 2.7.9 recipe to match how the python 3 recipe handles libffi by configuring the build to use the system libffi. This brings consistency between the libffi used for different python versions as well as with the system. (From OE-Core master rev: 4302cc20dbe0f0490a5e7b62baeb632322c40200) Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python_2.7.9.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.9.bb b/meta/recipes-devtools/python/python_2.7.9.bb
index 0031b8f453..7918550eae 100644
--- a/meta/recipes-devtools/python/python_2.7.9.bb
+++ b/meta/recipes-devtools/python/python_2.7.9.bb
@@ -1,5 +1,5 @@
require python.inc
-DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
+DEPENDS = "python-native libffi bzip2 db gdbm openssl readline sqlite3 zlib"
PR = "${INC_PR}"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
@@ -32,6 +32,8 @@ S = "${WORKDIR}/Python-${PV}"
inherit autotools multilib_header python-dir pythonnative
+CONFIGUREOPTS += " --with-system-ffi "
+
# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources
#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :(
TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"