aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-07-27 14:59:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 12:44:28 +0100
commit4cc30de57dd70571005a1f31f9465d745c92aad2 (patch)
tree93e3483237a76396bbed26724e0625afdf3417cd /meta/recipes-devtools
parent0176e798364689774bed4ac4bd0e345c32ea3078 (diff)
downloadopenembedded-core-contrib-4cc30de57dd70571005a1f31f9465d745c92aad2.tar.gz
python3-pbr: add it for python3-testtools
- The python3-testtools RDEPENDS on it. - It is from meta-python, I extended it to nativesdk. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-pbr.inc15
-rw-r--r--meta/recipes-devtools/python/python3-pbr_3.1.1.bb2
2 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pbr.inc b/meta/recipes-devtools/python/python-pbr.inc
new file mode 100644
index 0000000000..0b708838d6
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pbr.inc
@@ -0,0 +1,15 @@
+SUMMARY = "Python Build Reasonableness"
+DESCRIPTION = "PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
+HOMEPAGE = "https://pypi.python.org/pypi/pbr"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "4e82c2e07af544c56a5b71c801525b00"
+SRC_URI[sha256sum] = "05f61c71aaefc02d8e37c0a3eeb9815ff526ea28b3b76324769e6158d7f95be1"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pip"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-pbr_3.1.1.bb b/meta/recipes-devtools/python/python3-pbr_3.1.1.bb
new file mode 100644
index 0000000000..97e7361b16
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pbr_3.1.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pbr.inc