aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-07-27 15:36:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 12:44:28 +0100
commit50864df5b0eb3d1704e8fe75c06e957af0b41c38 (patch)
treeada98485ad6470e7913f5891930330eb27ac8a97 /meta/recipes-devtools
parent4cc30de57dd70571005a1f31f9465d745c92aad2 (diff)
downloadopenembedded-core-contrib-50864df5b0eb3d1704e8fe75c06e957af0b41c38.tar.gz
python3-testtools: add it for oeqa
- It is required by oeqa, add it so that we can add nativesdk-python3-testtools to buildtools-tarball. - The original one is python-testtools_2.3.0.bb which is from meta-openstack layer, I divided it into python-testtools.inc and python3-testtools_2.2.0.bb, and extended to nativesdk. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-testtools.inc27
-rw-r--r--meta/recipes-devtools/python/python3-testtools_2.2.0.bb2
2 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-testtools.inc b/meta/recipes-devtools/python/python-testtools.inc
new file mode 100644
index 0000000000..fe1d49a8aa
--- /dev/null
+++ b/meta/recipes-devtools/python/python-testtools.inc
@@ -0,0 +1,27 @@
+SUMMARY = "Extensions to the Python standard library unit testing framework"
+HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
+
+inherit pypi
+
+SRC_URI[md5sum] = "adef817b07ba24fd6d807fd41a4f1ef4"
+SRC_URI[sha256sum] = "80f606607a6e4ce4d0e24e5b786562aa42c581906f3c070607a4265f3da65810"
+
+DEPENDS += " \
+ ${PYTHON_PN}-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ ${PYTHON_PN}-pbr-native \
+ "
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-extras \
+ ${PYTHON_PN}-pbr \
+ ${PYTHON_PN}-six \
+ "
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-testtools_2.2.0.bb b/meta/recipes-devtools/python/python3-testtools_2.2.0.bb
new file mode 100644
index 0000000000..896ecee65c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-testtools_2.2.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-testtools.inc