summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>2015-11-17 15:14:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-01 21:30:56 +0000
commit91165c1b68e49e5d5392068df3412ebb7b0e969b (patch)
tree02cca8b88cd0a81a2257f3dee0446ca87c30afb8 /meta/recipes-devtools
parent981626d8cee345d27b7c9d96e941fd6622f47792 (diff)
downloadopenembedded-core-contrib-91165c1b68e49e5d5392068df3412ebb7b0e969b.tar.gz
python-git: Add missing dependency
Python-git depends on getpass, which is part of python-unixadmin. If it is missing: root@qt5022:~# python Python 2.7.9 (default, Nov 12 2015, 17:41:32) [GCC 5.2.0] on linux2 Type "help", "copyright", "credits" or "license" for more information. >>> import git Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib/python2.7/site-packages/git/__init__.py", line 35, in <module> from git.config import GitConfigParser File "/usr/lib/python2.7/site-packages/git/config.py", line 21, in <module> from git.util import LockFile File "/usr/lib/python2.7/site-packages/git/util.py", line 14, in <module> import getpass ImportError: No module named getpass >>> Reported-by: Dimitrios Katsaros <patcherwork@gmail.com> Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-git_1.0.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-git_1.0.1.bb b/meta/recipes-devtools/python/python-git_1.0.1.bb
index a78d7c83c4..e1509e6c20 100644
--- a/meta/recipes-devtools/python/python-git_1.0.1.bb
+++ b/meta/recipes-devtools/python/python-git_1.0.1.bb
@@ -18,6 +18,6 @@ S = "${WORKDIR}/GitPython-${PV}"
inherit setuptools
-RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold"
+RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold python-unixadmin"
BBCLASSEXTEND = "nativesdk"