summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-08-05 19:40:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-08 10:51:28 +0100
commitae41e1f263d20d5d83b2a7ca95dc955840d793e1 (patch)
tree005817a6851bbdf06d7eb093aa28ae01d9ef2233 /meta/recipes-extended/bash
parentb180fbd9d93db1c6351e183fbc08fc81cdc240c0 (diff)
downloadopenembedded-core-contrib-ae41e1f263d20d5d83b2a7ca95dc955840d793e1.tar.gz
bash: add -fomit-frame-pointer to DEBUG_OPTIMIZATION for armv[45] with thumb enabled
with thumb and debug enabled bash gets stuck forever when building for qemuarm. bash/4.4.18-r0/build/builtins$ arm-webos-linux-gnueabi-gcc -march=armv5te -mthumb -fstack-protector-strong --sysroot=bash/4.4.18-r0/recipe-sysroot -c -DHAVE_CONFIG_H -DSHELL -I. -I.. -I../../bash-4.4.18 -I../../bash-4.4.18/include -I../../bash-4.4.18/lib -I../../bash-4.4.18/builtins -O -fno-omit-frame-pointer -g -DNON_INTERACTIVE_LOGIN_SHELLS read.c when -mthumb, -fstack-protector-strong, -fno-omit-frame-pointer appear together, removing one of them is enough for successful build. similar to: http://lists.openembedded.org/pipermail/openembedded-core/2018-May/150654.html but in this case the build gets stuck instead of failure Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/bash')
-rw-r--r--meta/recipes-extended/bash/bash_4.4.18.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash_4.4.18.bb b/meta/recipes-extended/bash/bash_4.4.18.bb
index 0b22ca7a69..b338acd9dc 100644
--- a/meta/recipes-extended/bash/bash_4.4.18.bb
+++ b/meta/recipes-extended/bash/bash_4.4.18.bb
@@ -19,4 +19,7 @@ SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
SRC_URI[tarball.md5sum] = "518e2c187cc11a17040f0915dddce54e"
SRC_URI[tarball.sha256sum] = "604d9eec5e4ed5fd2180ee44dd756ddca92e0b6aa4217bbab2b6227380317f23"
+DEBUG_OPTIMIZATION_append_armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}"
+DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}"
+
BBCLASSEXTEND = "nativesdk"