summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2013-06-06 17:28:10 +0800
committerSaul Wold <sgw@linux.intel.com>2013-06-10 14:51:25 -0700
commit18f5e6b80e1465e00242a2513a4bd90e0a2f3ff7 (patch)
treec6f7196ca3c94368d191e62100cc70e1e6cdc51a /meta/recipes-extended/chkconfig
parentfa4d1526f639d50b578ff82b4e65ac45c612bcca (diff)
downloadopenembedded-core-contrib-18f5e6b80e1465e00242a2513a4bd90e0a2f3ff7.tar.gz
chkconfig: fix QA warning about unsafe references in binaries
This test is disabled in oe-core by default, but if we enable it, we'll get following warnings: + WARN_QA = "unsafe-references-in-binaries unsafe-references-in-scripts" WARNING: QA Issue: chkconfig: /sbin/chkconfig, installed in the \ base_prefix, requires a shared library under exec_prefix (/usr): \ libpopt.so.0 => /usr/lib64/libpopt.so.0 Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/chkconfig')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
index 4c6985fd39..c6f8b1d44f 100644
--- a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
+++ b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
@@ -43,7 +43,8 @@ obey_variables () {
}
do_install() {
- oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' install
+ oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' \
+ 'BINDIR=${sbindir}' install
install -d ${D}${sysconfdir}/chkconfig.d
}