summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cracklib
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-29 21:05:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-02 22:39:07 +0000
commitf24eb53979c18bdfc7b0806055de86e812d78e63 (patch)
treed6cac23dd8fc6dd0910273333468c639a00854dc /meta/recipes-extended/cracklib
parentf836f4bfd83862a1a0da7d4cc20ae9eaf62118da (diff)
downloadopenembedded-core-contrib-f24eb53979c18bdfc7b0806055de86e812d78e63.tar.gz
cracklib: fix Python packaging
Don't assume that we know precisely what Python files were installed as patching automake can change what optimised forms get installed by matching *.py* in FILES and not deleting *.pyo explictly. Similarly, remove all forms of test_cracklib from the packages. The python .la file is mostly redundant but if we're shipping it, put it in -python where it belongs instead of -staticdev. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/cracklib')
-rw-r--r--meta/recipes-extended/cracklib/cracklib_2.9.5.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta/recipes-extended/cracklib/cracklib_2.9.5.bb b/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
index 8c9063e07c..3bd3f93674 100644
--- a/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
+++ b/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
@@ -29,8 +29,7 @@ do_install_append_class-target() {
do_install_append() {
src_dir="${D}${base_libdir}/${PYTHON_DIR}/site-packages"
- rm -f $src_dir/*.pyo
- rm -f $src_dir/test_cracklib.py
+ rm -f $src_dir/test_cracklib.py*
if [ "${base_libdir}" != "${libdir}" ] ; then
# Move python files from ${base_libdir} to ${libdir} since used --libdir=${base_libdir}
@@ -42,9 +41,7 @@ do_install_append() {
BBCLASSEXTEND = "native nativesdk"
-FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/cracklib.py \
- ${PYTHON_SITEPACKAGES_DIR}/_cracklib.so \
- "
-FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_cracklib.a \
- ${PYTHON_SITEPACKAGES_DIR}/_cracklib.la \
- "
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/cracklib.py* \
+ ${PYTHON_SITEPACKAGES_DIR}/_cracklib.*"
+
+FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_cracklib.a"