summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/diffutils
diff options
context:
space:
mode:
authorPeiran Hong <Peiran.Hong@windriver.com>2019-09-06 16:44:19 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-07 13:08:27 +0100
commit802c67c7c27011812d690c41347b38481cdab2e9 (patch)
tree3efb3fd75599cc72699e21099e243d4fdd9c17c3 /meta/recipes-extended/diffutils
parente4eb3ca113985ab2be123eb5b5ea76764761df88 (diff)
downloadopenembedded-core-contrib-802c67c7c27011812d690c41347b38481cdab2e9.tar.gz
diffutils: Added perl to support ptest & Skipped one test case
Added perl to the run-time dependency of the recipe for diffutils since it is required by the test "large-subpot". The test "strip-trailing-cr" is skipped since it requires valgrind to work, but valgrind is considered too heavy-weight for diffutils package. Signed-off-by: Peiran Hong <peiran.hong@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/diffutils')
-rw-r--r--meta/recipes-extended/diffutils/diffutils/0001-Skip-strip-trailing-cr-test-case.patch35
-rw-r--r--meta/recipes-extended/diffutils/diffutils_3.7.bb3
2 files changed, 37 insertions, 1 deletions
diff --git a/meta/recipes-extended/diffutils/diffutils/0001-Skip-strip-trailing-cr-test-case.patch b/meta/recipes-extended/diffutils/diffutils/0001-Skip-strip-trailing-cr-test-case.patch
new file mode 100644
index 0000000000..aac1c43465
--- /dev/null
+++ b/meta/recipes-extended/diffutils/diffutils/0001-Skip-strip-trailing-cr-test-case.patch
@@ -0,0 +1,35 @@
+From bd7fb8be2ae2d75347cf7733302d5093046ffa85 Mon Sep 17 00:00:00 2001
+From: Peiran Hong <peiran.hong@windriver.com>
+Date: Thu, 5 Sep 2019 15:42:22 -0400
+Subject: [PATCH] Skip strip-trailing-cr test case
+
+Skip the test "strip-trailing-cr" since it requires valgrind to
+work, but valgrind is considered too heavy-weight for diffutils
+package.
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Peiran Hong <peiran.hong@windriver.com>
+---
+ tests/Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 83a7c9d..04d51b5 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -21,8 +21,10 @@ TESTS = \
+ stdin \
+ strcoll-0-names \
+ filename-quoting \
+- strip-trailing-cr \
+ colors
++# Skipping this test since it requires valgrind
++# and thus is too heavy for diffutils package
++# strip-trailing-cr
+
+ XFAIL_TESTS = large-subopt
+
+--
+2.21.0
+
diff --git a/meta/recipes-extended/diffutils/diffutils_3.7.bb b/meta/recipes-extended/diffutils/diffutils_3.7.bb
index 7daeee3513..8111ae6065 100644
--- a/meta/recipes-extended/diffutils/diffutils_3.7.bb
+++ b/meta/recipes-extended/diffutils/diffutils_3.7.bb
@@ -5,6 +5,7 @@ require diffutils.inc
SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
file://run-ptest \
+ file://0001-Skip-strip-trailing-cr-test-case.patch \
"
SRC_URI[md5sum] = "4824adc0e95dbbf11dfbdfaad6a1e461"
@@ -17,7 +18,7 @@ acpaths = "-I ./m4"
inherit ptest
-RDEPENDS_${PN}-ptest += "make"
+RDEPENDS_${PN}-ptest += "make perl"
do_install_ptest() {
t=${D}${PTEST_PATH}