aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript/base-genht.c-add-a-preprocessor-define-to-allow-fope.patch
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-06-17 19:03:02 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-17 17:55:08 +0100
commit44ad25519b8e290f9a98b88eeec52ba199e76431 (patch)
treec49d7dbdb58a0b8a7bed4261e09376ec3898ea06 /meta/recipes-extended/ghostscript/ghostscript/base-genht.c-add-a-preprocessor-define-to-allow-fope.patch
parent55b6d5fac389f55089018574cc2b4ef8217f1b0d (diff)
downloadopenembedded-core-contrib-44ad25519b8e290f9a98b88eeec52ba199e76431.tar.gz
ghostscript: upgrade to 9.14
- The LICENSE added AGPL for the font files (in Resource/Font); - Rebase ghostscript-9.02-parallel-make.patch to 9.14 - Rebase ghostscript-native-fix-disable-system-libtiff.patch since base/configure.ac has been moved to configure.ac. http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=f1488c5aff54f37ee67759827d4298592af5dbc8 - Obsolete ghostscript-9.05-NOT-check-endian.patch, and add option '--enable-little-endian'/'--enable-big-endian' conditionally to intead. http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=e76dc46756e89a14a3348bce12a633d32e4fa831 - Add base-genht.c-add-a-preprocessor-define-to-allow-fope.patch for native, since the upstream replace all fopen calls with gp_fopen and add a preprocessor define so that any unintential calls directly to fopen will cause an error. This patch add a preprocessor define to allow fopen calling in base/genht.c as exceptions. http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=773c69e46e70bdd5482676437dafd2ca83397643 - Remove package ghostscript-cups, since CUPS filters gstoraster and gstopxl has been moved to cups-filters which is a free software package hosted by OpenPrinting. http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=9304a21699a6c17579fae32f44f5c92a37c13e2d http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript/base-genht.c-add-a-preprocessor-define-to-allow-fope.patch')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript/base-genht.c-add-a-preprocessor-define-to-allow-fope.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript/base-genht.c-add-a-preprocessor-define-to-allow-fope.patch b/meta/recipes-extended/ghostscript/ghostscript/base-genht.c-add-a-preprocessor-define-to-allow-fope.patch
new file mode 100644
index 0000000000..d97d4ecd7d
--- /dev/null
+++ b/meta/recipes-extended/ghostscript/ghostscript/base-genht.c-add-a-preprocessor-define-to-allow-fope.patch
@@ -0,0 +1,36 @@
+base/genht.c: add a preprocessor define to allow fopen calling
+
+The commit in upstream:
+http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=773c69e46e70bdd5482676437dafd2ca83397643
+
+Replace all fopen calls with gp_fopen and add a preprocessor define so
+that any unintential calls directly to fopen will cause an error.
+
+Only exceptions are those in the platform specific code, and mkromfs.c.
+This patch add a preprocessor define to allow fopen calling in base/genht.c.
+
+Upstream-Status: Pending
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ base/genht.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/base/genht.c b/base/genht.c
+index 4b04085..cc82fff 100644
+--- a/base/genht.c
++++ b/base/genht.c
+@@ -16,6 +16,10 @@
+
+ /* Generate C code for compiling halftones into ROM. */
+ #include "malloc_.h"
++
++/* prevent gp.h from defining fopen */
++#define fopen fopen
++
+ #include "stdio_.h"
+ #include "string_.h"
+ #include "gscdefs.h"
+--
+1.8.1.2
+