summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-03-28 14:01:17 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-31 12:26:46 +0100
commit2799eda9f373b430ad64c8b61f8047abce7f1e22 (patch)
tree7bead7787f449a9b090315ff7e515a4a2850fdbd /meta/recipes-extended/lsb
parentb77cf437e89a2ec21de6a69d5e34736925f1eeba (diff)
downloadopenembedded-core-contrib-2799eda9f373b430ad64c8b61f8047abce7f1e22.tar.gz
lsb: Avoid using double slashes in paths
Use ${D}${var} rather than ${D}/${var} for variables where ${var} contains an absolute path. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb')
-rw-r--r--meta/recipes-extended/lsb/lsb_4.1.bb49
1 files changed, 25 insertions, 24 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb
index 39cb5445e2..2eb67b8c3a 100644
--- a/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/meta/recipes-extended/lsb/lsb_4.1.bb
@@ -33,10 +33,10 @@ S = "${WORKDIR}/lsb-release-1.4"
CLEANBROKEN = "1"
-do_install(){
- oe_runmake install prefix=${D}/${base_prefix} mandir=${D}/${datadir}/man/ DESTDIR=${D}
+do_install() {
+ oe_runmake install prefix=${D}${base_prefix} mandir=${D}${datadir}/man/ DESTDIR=${D}
- # this 2 dirs are needed by package lsb-dist-checker
+ # these two dirs are needed by package lsb-dist-checker
mkdir -p ${D}${sysconfdir}/opt
mkdir -p ${D}${localstatedir}/opt
@@ -44,7 +44,7 @@ do_install(){
mkdir -p ${D}${sysconfdir}/lsb-release.d
printf "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release
- if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
+ if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then
printf "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release
else
printf "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release
@@ -57,73 +57,74 @@ do_install(){
fi
echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}${sysconfdir}/lsb-release
- if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
+ if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then
mkdir -p ${D}${sysconfdir}/lsb-release.d
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ia32
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ia32
- elif [ "${TARGET_ARCH}" = "x86_64" ];then
+ elif [ "${TARGET_ARCH}" = "x86_64" ]; then
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-amd64
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-amd64
fi
- if [ "${TARGET_ARCH}" = "powerpc" ];then
+ if [ "${TARGET_ARCH}" = "powerpc" ]; then
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc32
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc32
- elif [ "${TARGET_ARCH}" = "powerpc64" ];then
+ elif [ "${TARGET_ARCH}" = "powerpc64" ]; then
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc64
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc64
fi
}
-do_install_append(){
+do_install_append() {
install -d ${D}${sysconfdir}/core-lsb
for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon
do
- install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb
+ install -m 0755 ${WORKDIR}/$i ${D}${sysconfdir}/core-lsb
done
- install -d ${D}/${nonarch_base_libdir}/lsb
- install -m 0755 ${WORKDIR}/init-functions ${D}/${nonarch_base_libdir}/lsb
+ install -d ${D}${nonarch_base_libdir}/lsb
+ install -m 0755 ${WORKDIR}/init-functions ${D}${nonarch_base_libdir}/lsb
- # creat links for LSB test
+ # create links for LSB test
if [ "${nonarch_base_libdir}" != "${nonarch_libdir}" ] ; then
- install -d ${D}/${nonarch_libdir}/lsb
+ install -d ${D}${nonarch_libdir}/lsb
fi
- ln -sf ${sbindir}/chkconfig ${D}/${nonarch_libdir}/lsb/install_initd
- ln -sf ${sbindir}/chkconfig ${D}/${nonarch_libdir}/lsb/remove_initd
+ ln -sf ${sbindir}/chkconfig ${D}${nonarch_libdir}/lsb/install_initd
+ ln -sf ${sbindir}/chkconfig ${D}${nonarch_libdir}/lsb/remove_initd
- if [ "${TARGET_ARCH}" = "x86_64" ];then
+ if [ "${TARGET_ARCH}" = "x86_64" ]; then
if [ "${baselib}" != "lib64" ]; then
lnr ${D}${base_libdir} ${D}/lib64
fi
- cd ${D}/${base_libdir}
+ cd ${D}${base_libdir}
ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2
ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3
fi
- if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
- cd ${D}/${base_libdir}
+ if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then
+ cd ${D}${base_libdir}
ln -sf ld-linux.so.2 ld-lsb.so.2
ln -sf ld-linux.so.2 ld-lsb.so.3
fi
- if [ "${TARGET_ARCH}" = "powerpc64" ];then
+ if [ "${TARGET_ARCH}" = "powerpc64" ]; then
if [ "${baselib}" != "lib64" ]; then
lnr ${D}${base_libdir} ${D}/lib64
fi
- cd ${D}/${base_libdir}
+ cd ${D}${base_libdir}
ln -sf ld64.so.1 ld-lsb-ppc64.so.2
ln -sf ld64.so.1 ld-lsb-ppc64.so.3
fi
- if [ "${TARGET_ARCH}" = "powerpc" ];then
- cd ${D}/${base_libdir}
+ if [ "${TARGET_ARCH}" = "powerpc" ]; then
+ cd ${D}${base_libdir}
ln -sf ld.so.1 ld-lsb-ppc32.so.2
ln -sf ld.so.1 ld-lsb-ppc32.so.3
fi
}
+
FILES_${PN} += "${@'/lib64' if d.getVar('TARGET_ARCH') == ('x86_64' or 'powerpc64') and '${baselib}' != 'lib64' else ''} \
${base_libdir} \
${nonarch_libdir}/lsb \