summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-12 07:59:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-13 10:46:30 +0100
commitaf314c17f6c32afbed9a277775156b9bbc5ac033 (patch)
tree2207a8b2832691054feb7ae515cca76d4fee9e0e /meta/recipes-extended/ltp
parent0b0f545dbf16b0970c5a79975d451dc9d887c2a7 (diff)
downloadopenembedded-core-contrib-af314c17f6c32afbed9a277775156b9bbc5ac033.tar.gz
ltp: Include stdint.h for uintptr_t
Fixes build with musl and upcoming glibc Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/0001-dirtyc0w-Include-stdint.h.patch34
-rw-r--r--meta/recipes-extended/ltp/ltp_20170516.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0001-dirtyc0w-Include-stdint.h.patch b/meta/recipes-extended/ltp/ltp/0001-dirtyc0w-Include-stdint.h.patch
new file mode 100644
index 0000000000..5c73be440b
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0001-dirtyc0w-Include-stdint.h.patch
@@ -0,0 +1,34 @@
+From 1b30d8dac1a37dc0abbb3b545db2824d6489e23f Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 9 Jun 2017 09:32:13 -0700
+Subject: [PATCH] dirtyc0w: Include stdint.h
+
+uintptr_t is defined in stdint.h
+
+Fixes
+| dirtyc0w_child.c:76:15: error: 'uintptr_t' undeclared (first use in this function); did you mean 'intptr_t'?
+| lseek(mfd, (uintptr_t) map, SEEK_SET);
+| ^~~~~~~~~
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ testcases/kernel/security/dirtyc0w/dirtyc0w_child.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/testcases/kernel/security/dirtyc0w/dirtyc0w_child.c b/testcases/kernel/security/dirtyc0w/dirtyc0w_child.c
+index 5328a9bc4..49abdd6ba 100644
+--- a/testcases/kernel/security/dirtyc0w/dirtyc0w_child.c
++++ b/testcases/kernel/security/dirtyc0w/dirtyc0w_child.c
+@@ -23,6 +23,7 @@
+ #include <sys/stat.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <stdint.h>
+ #include <pwd.h>
+
+ #include "tst_safe_pthread.h"
+--
+2.13.1
+
diff --git a/meta/recipes-extended/ltp/ltp_20170516.bb b/meta/recipes-extended/ltp/ltp_20170516.bb
index 012c43de35..31f339461f 100644
--- a/meta/recipes-extended/ltp/ltp_20170516.bb
+++ b/meta/recipes-extended/ltp/ltp_20170516.bb
@@ -50,6 +50,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0034-periodic_output.patch \
file://0035-fix-test_proc_kill-hang.patch \
file://0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
+ file://0001-dirtyc0w-Include-stdint.h.patch \
"
S = "${WORKDIR}/git"