aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-12-01 14:54:02 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-12 21:50:17 +0000
commitcd044f6adb25005313497c5f47f07ac7d13ac6c8 (patch)
tree1412e112cab1805476717334664d2a4461084c74 /meta/recipes-extended/mdadm
parent3c96a5386355969428163ddb60216cc989e00b3d (diff)
downloadopenembedded-core-contrib-cd044f6adb25005313497c5f47f07ac7d13ac6c8.tar.gz
mdadm: Make custom CC definition conditional
By hardcoding CC's definition in the Makefile, all the gcc parameters set by tune settings are lost. Causing compile failure with x32 toolchain As the bitbake defined CC is good, there is no need to redfine CC in the make file, hence making the CC definition in the Makefile conditional. This fixes bug: [YOCTO #1414] (From OE-Core rev: c877ec8ff1dfbf0123f94711f44cea043815a9c1) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/files/mdadm-3.2.2_fix_for_x32.patch24
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.2.2.bb4
2 files changed, 26 insertions, 2 deletions
diff --git a/meta/recipes-extended/mdadm/files/mdadm-3.2.2_fix_for_x32.patch b/meta/recipes-extended/mdadm/files/mdadm-3.2.2_fix_for_x32.patch
new file mode 100644
index 0000000000..79ba2cf9e9
--- /dev/null
+++ b/meta/recipes-extended/mdadm/files/mdadm-3.2.2_fix_for_x32.patch
@@ -0,0 +1,24 @@
+UpstreamStatus: pending
+
+By hardcoding CC's definition in the Makefile, all the gcc parameters
+set by tune settings are lost. Causing compile failure with x32 toolchain
+
+As the bitbake defined CC is good, there is no need to redfine CC in the
+make file, hence making the CC definition in the Makefile conditional.
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/12/07
+
+Index: mdadm-3.2.2/Makefile
+===================================================================
+--- mdadm-3.2.2.orig/Makefile
++++ mdadm-3.2.2/Makefile
+@@ -40,7 +40,8 @@ KLIBC=/home/src/klibc/klibc-0.77
+
+ KLIBC_GCC = gcc -nostdinc -iwithprefix include -I$(KLIBC)/klibc/include -I$(KLIBC)/linux/include -I$(KLIBC)/klibc/arch/i386/include -I$(KLIBC)/klibc/include/bits32
+
+-CC = $(CROSS_COMPILE)gcc
++CC ?= $(CROSS_COMPILE)gcc
++
+ CXFLAGS = -ggdb
+ CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
+ ifdef WARN_UNUSED
diff --git a/meta/recipes-extended/mdadm/mdadm_3.2.2.bb b/meta/recipes-extended/mdadm/mdadm_3.2.2.bb
index 97878edb68..02109e36ac 100644
--- a/meta/recipes-extended/mdadm/mdadm_3.2.2.bb
+++ b/meta/recipes-extended/mdadm/mdadm_3.2.2.bb
@@ -8,10 +8,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
-PR = "r2"
+PR = "r3"
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
file://0001-mdadm-fix-build-failures-ppc64.patch \
+ file://mdadm-3.2.2_fix_for_x32.patch \
"
SRC_URI[md5sum] = "12ee2fbf3beddb60601fb7a4c4905651"
@@ -22,7 +23,6 @@ CFLAGS += "-fno-strict-aliasing"
inherit autotools
do_compile() {
- export CROSS_COMPILE="${TARGET_PREFIX}"
oe_runmake
}