summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorAmarnath Valluri <amarnath.valluri@intel.com>2017-03-03 14:27:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-21 22:43:01 +0000
commit9e01148176341916b1fcfebe46d70b75b42777d5 (patch)
treec36916d636480763c5c45914afa2629124312ca8 /meta/recipes-extended/mdadm
parentd0f99c7f264fb99e7a940e9b02d27a418bafad27 (diff)
downloadopenembedded-core-contrib-9e01148176341916b1fcfebe46d70b75b42777d5.tar.gz
mdadm: Avoid using hardocded sbin path
Use appropriate bitbake variable inplace of hardcoded sbin path in Makefile Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.0.bb b/meta/recipes-extended/mdadm/mdadm_4.0.bb
index c2288995ba..62614f060f 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.0.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.0.bb
@@ -33,6 +33,8 @@ CFLAGS_append_mipsarchn64 = ' -D__SANE_USERSPACE_TYPES__'
CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
do_compile() {
+ # Point to right sbindir
+ sed -i -e "s;BINDIR = /sbin;BINDIR = $base_sbindir;" ${S}/Makefile
oe_runmake SYSROOT="${STAGING_DIR_TARGET}"
}
@@ -51,7 +53,7 @@ do_install_ptest() {
cp -a ${S}/tests ${D}${PTEST_PATH}/tests
cp ${S}/test ${D}${PTEST_PATH}
sed -e 's!sleep 0.*!sleep 1!g; s!/var/tmp!/!g' -i ${D}${PTEST_PATH}/test
- ln -s /sbin/mdadm ${D}${PTEST_PATH}/mdadm
+ ln -s ${base_sbindir}/mdadm ${D}${PTEST_PATH}/mdadm
for prg in test_stripe swap_super raid6check
do
install -D -m 755 $prg ${D}${PTEST_PATH}/