aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/msmtp/msmtp_1.6.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-03 12:15:00 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-04 14:13:35 +0100
commit41f18826ac44456af7e8eb7ba53d52885ecd66f0 (patch)
tree20052fdf80274563b4d78064ccc597985b6bc571 /meta/recipes-extended/msmtp/msmtp_1.6.5.bb
parent9b937870cbe5dfaddb5a5b8e3405c9c03936667f (diff)
downloadopenembedded-core-contrib-41f18826ac44456af7e8eb7ba53d52885ecd66f0.tar.gz
msmtp: update to 1.6.5
(From OE-Core rev: c4f58052e13ebd9dd58ebe4a654ae725e10e85f8) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/msmtp/msmtp_1.6.5.bb')
-rw-r--r--meta/recipes-extended/msmtp/msmtp_1.6.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/msmtp/msmtp_1.6.5.bb b/meta/recipes-extended/msmtp/msmtp_1.6.5.bb
new file mode 100644
index 0000000000..d0c39eb4d6
--- /dev/null
+++ b/meta/recipes-extended/msmtp/msmtp_1.6.5.bb
@@ -0,0 +1,30 @@
+SUMMARY = "msmtp is an SMTP client"
+DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
+HOMEPAGE = "http://msmtp.sourceforge.net/"
+SECTION = "console/network"
+
+LICENSE = "GPLv3"
+DEPENDS = "zlib gnutls"
+
+#COPYING or Licence
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "http://sourceforge.net/projects/msmtp/files/msmtp/${PV}/${BPN}-${PV}.tar.xz \
+ "
+
+SRC_URI[md5sum] = "50a8c9bb72f8222779db6b4aae2965e0"
+SRC_URI[sha256sum] = "76a0d60693c7e65d0c7a12f01d300882d280b1e1be0202f54730ae44d44a5006"
+
+inherit gettext autotools update-alternatives pkgconfig
+
+EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn"
+
+ALTERNATIVE_${PN} = "sendmail"
+ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
+ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
+ALTERNATIVE_PRIORITY = "100"
+
+pkg_postinst_${PN}_linuxstdbase () {
+ # /usr/lib/sendmial is required by LSB core test
+ [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/
+}