aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.18.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-11-25 11:25:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-03 12:19:23 +0000
commit5239060e99da82134387787e544e724500a6ab41 (patch)
treec4da98381c06da4ee41746db3f3a163661641f26 /meta/recipes-extended/newt/libnewt_0.52.18.bb
parente884548dabab7ac1d45c469390f3238f57dbb684 (diff)
downloadopenembedded-core-contrib-5239060e99da82134387787e544e724500a6ab41.tar.gz
libnewt/libnewt-python: upgrade to 0.52.18
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.18.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.18.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.18.bb b/meta/recipes-extended/newt/libnewt_0.52.18.bb
new file mode 100644
index 0000000000..e8ac66269a
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.18.bb
@@ -0,0 +1,52 @@
+SUMMARY = "A library for text mode user interfaces"
+
+DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
+interfaces. Newt can be used to add stacked windows, entry widgets, \
+checkboxes, radio buttons, labels, plain text fields, scrollbars, \
+etc., to text mode user interfaces. This package also contains the \
+shared library needed by programs built with newt, as well as a \
+/usr/bin/dialog replacement called whiptail. Newt is based on the \
+slang library."
+
+HOMEPAGE = "https://fedorahosted.org/newt/"
+SECTION = "libs"
+
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+# slang needs to be >= 2.2
+DEPENDS = "slang popt"
+
+SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
+ file://remove_slang_include.patch \
+ file://fix_SHAREDDIR.patch \
+ file://cross_ar.patch \
+"
+
+SRC_URI[md5sum] = "685721bee1a318570704b19dcf31d268"
+SRC_URI[sha256sum] = "771b0e634ede56ae6a6acd910728bb5832ac13ddb0d1d27919d2498dab70c91e"
+
+S = "${WORKDIR}/newt-${PV}"
+
+EXTRA_OECONF = "--without-tcl --without-python"
+
+inherit autotools-brokensep
+
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+export BUILD_SYS
+export HOST_SYS
+
+PACKAGES_prepend = "whiptail "
+
+do_configure_prepend() {
+ sh autogen.sh
+}
+
+do_compile_prepend() {
+ # Make sure the recompile is OK
+ rm -f ${B}/.depend
+}
+
+FILES_whiptail = "${bindir}/whiptail"