aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-23 00:15:14 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2018-03-23 01:39:24 -0700
commit6a370ef551dfc53b3104a11c2c2c9966fa7686cd (patch)
tree7e57ceea403491f76a809c588ccdd6d49bcd76ad /meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
parent7ee36fcc4da9c00ab9ab8f89d60558a47402abde (diff)
downloadopenembedded-core-contrib-timo/libxml-simple-perl-2.25.tar.gz
libxml-namespacesupport: use stable v1.12 release; inherit ptest-perltimo/libxml-simple-perl-2.25
* Fix RDEPENDS * Upstream v1.12_9 is a development version, not a stable release * Add UPSTREAM_CHECK_REGEX skip development releases * Drop anonymous python function to "fix" version, which breaks auto-upgrade-helper (AUH) * Use LICENSE file for checksum rather than ephemeral META.yml * License remains the same Fixes: [YOCTO #12581] License-Update: use LICENSE file for checksum Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb')
-rw-r--r--meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
new file mode 100644
index 0000000000..fa9f9954bb
--- /dev/null
+++ b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Perl module for supporting simple generic namespaces"
+HOMEPAGE = "http://veillard.com/XML/"
+DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-based XML names. \
+ It also helps maintain a prefix-to-namespace URI map, and provides a number of \
+ basic checks. "
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+SRCNAME = "XML-NamespaceSupport"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c9d8a117e7620b5adf8d69c29613ceab"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PE/PERIGRIN/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "a8916c6d095bcf073e1108af02e78c97"
+SRC_URI[sha256sum] = "47e995859f8dd0413aa3f22d350c4a62da652e854267aa0586ae544ae2bae5ef"
+
+UPSTREAM_CHECK_REGEX = "XML\-NamespaceSupport\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit cpan ptest-perl
+
+RDEPENDS_${PN}-ptest += "perl-module-test-more"
+
+BBCLASSEXTEND="native"
+