summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/procps
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-08-23 22:18:12 +0800
committerSaul Wold <sgw@linux.intel.com>2011-08-24 08:47:30 -0700
commit7e3e69d38898876ba3325852bbec04586635e66f (patch)
tree18965be0f50928b595532c4ef855a2010ea1f8ce /meta/recipes-extended/procps
parent4570c1e4f5ba3f3c2f5be8b46d47efc3921d3e6b (diff)
downloadopenembedded-core-contrib-7e3e69d38898876ba3325852bbec04586635e66f.tar.gz
procps: Fix lib path to support multilib
Revise the install.patch which hardcode the lib paths. Change ${PN} to ${BPN} in file names. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-extended/procps')
-rw-r--r--meta/recipes-extended/procps/procps-3.2.8/install.patch30
-rw-r--r--meta/recipes-extended/procps/procps_3.2.8.bb8
2 files changed, 24 insertions, 14 deletions
diff --git a/meta/recipes-extended/procps/procps-3.2.8/install.patch b/meta/recipes-extended/procps/procps-3.2.8/install.patch
index b52a2c9141..2a59a5ff68 100644
--- a/meta/recipes-extended/procps/procps-3.2.8/install.patch
+++ b/meta/recipes-extended/procps/procps-3.2.8/install.patch
@@ -1,20 +1,30 @@
Upstream-Status: Inappropriate [configuration]
---- procps-3.2.5.virgin/Makefile 2005-01-26 05:55:26.000000000 +0100
-+++ procps-3.2.5/Makefile 2005-08-03 04:55:26.346984488 +0200
-@@ -30,7 +30,10 @@
+diff -ruN procps-3.2.8-orig//Makefile procps-3.2.8/Makefile
+--- procps-3.2.8-orig//Makefile 2011-08-23 22:06:46.471163999 +0800
++++ procps-3.2.8/Makefile 2011-08-23 22:15:01.091163999 +0800
+@@ -29,9 +29,6 @@
+ ln_sf := ln -sf
install := install -D --owner 0 --group 0
- # Lame x86-64 /lib64 and /usr/lib64 abomination:
+-# Lame x86-64 /lib64 and /usr/lib64 abomination:
-lib64 := lib$(shell [ -d /lib64 ] && echo 64)
-+# lib64 := lib$(shell [ -d /lib64 ] && echo 64)
-+
-+# Equally lame hack to work around makefile lameness when the host arch is 64bit, but the target is not.
-+lib64 := lib
-
+-
usr/bin := $(DESTDIR)/usr/bin/
bin := $(DESTDIR)/bin/
-@@ -211,10 +214,10 @@
+ sbin := $(DESTDIR)/sbin/
+@@ -39,8 +36,8 @@
+ man1 := $(DESTDIR)/usr/share/man/man1/
+ man5 := $(DESTDIR)/usr/share/man/man5/
+ man8 := $(DESTDIR)/usr/share/man/man8/
+-lib := $(DESTDIR)/$(lib64)/
+-usr/lib := $(DESTDIR)/usr/$(lib64)/
++lib := $(DESTDIR)/$(base_libdir)/
++usr/lib := $(DESTDIR)/$(libdir)/
+ usr/include := $(DESTDIR)/usr/include/
+
+ #SKIP := $(bin)kill $(man1)kill.1
+@@ -222,10 +219,10 @@
###### install
$(BINFILES) : all
diff --git a/meta/recipes-extended/procps/procps_3.2.8.bb b/meta/recipes-extended/procps/procps_3.2.8.bb
index b1a7de7050..a38077eae2 100644
--- a/meta/recipes-extended/procps/procps_3.2.8.bb
+++ b/meta/recipes-extended/procps/procps_3.2.8.bb
@@ -1,6 +1,6 @@
require procps.inc
-PR = "r1"
+PR = "r2"
inherit update-rc.d update-alternatives
@@ -22,10 +22,10 @@ SRC_URI += "file://procmodule.patch \
SRC_URI[md5sum] = "9532714b6846013ca9898984ba4cd7e0"
SRC_URI[sha256sum] = "11ed68d8a4433b91cd833deb714a3aa849c02aea738c42e6b4557982419c1535"
-FILES = "${bindir}/top.${PN} ${base_bindir}/ps.${PN} ${bindir}/uptime.${PN} ${base_bindir}/kill.${PN} \
- ${bindir}/free.${PN} ${bindir}/w ${bindir}/watch ${bindir}/pgrep ${bindir}/pmap ${bindir}/pwdx \
+FILES = "${bindir}/top.${BPN} ${base_bindir}/ps.${BPN} ${bindir}/uptime.${BPN} ${base_bindir}/kill.${BPN} \
+ ${bindir}/free.${BPN} ${bindir}/w ${bindir}/watch ${bindir}/pgrep ${bindir}/pmap ${bindir}/pwdx \
${bindir}/snice ${bindir}/vmstat ${bindir}/slabtop ${bindir}/pkill ${bindir}/skill ${bindir}/tload \
- ${base_sbindir}/sysctl.${PN}"
+ ${base_sbindir}/sysctl.${BPN}"
CONFFILES_${PN} = "${sysconfdir}/sysctl.conf"