summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sudo
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-06-23 12:10:22 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-08 10:20:08 +0000
commit431ad7a268fc07c367ce830c4f69dba515f44b4e (patch)
treecbdd5a19efcd1c947b001ec11ba3422a1257f4f7 /meta/recipes-extended/sudo
parent705a369e5f48dc75f2db4ef814f63d11c2285058 (diff)
downloadopenembedded-core-contrib-431ad7a268fc07c367ce830c4f69dba515f44b4e.tar.gz
sudo: handle libexecdir != libdir/PN.
sudo has somewhat special file installation logic and installs the modules and libraries to $libexecdir/sudo, with special handling for the case when libexecdir already contains /sudo (which it does by default in current oe-core where libexecdir=$libdir/$PN). As setting libexecdir to /usr/libexec should work, add both possibilities to FILES to be sure the right files are captured, and add INSANE_SKIP for the libdir warning that libraries are outside of /usr/lib/ (arguably, this should be fixed in insane). Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/sudo')
-rw-r--r--meta/recipes-extended/sudo/sudo.inc5
-rw-r--r--meta/recipes-extended/sudo/sudo_1.8.14p3.bb3
2 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-extended/sudo/sudo.inc b/meta/recipes-extended/sudo/sudo.inc
index a25876b7fc..48ed4362d9 100644
--- a/meta/recipes-extended/sudo/sudo.inc
+++ b/meta/recipes-extended/sudo/sudo.inc
@@ -38,3 +38,8 @@ do_compile_prepend () {
do_install_prepend (){
mkdir -p ${D}/${localstatedir}/lib
}
+
+# Sudo insists on putting libraries into libexecdir
+INSANE_SKIP_${PN} += "libdir"
+INSANE_SKIP_${PN}-dev += "libdir"
+INSANE_SKIP_${PN}-dbg += "libdir"
diff --git a/meta/recipes-extended/sudo/sudo_1.8.14p3.bb b/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
index b93112fa3f..4db85e23f8 100644
--- a/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
+++ b/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
@@ -33,4 +33,5 @@ do_install_append () {
}
FILES_${PN} += "${libdir}/tmpfiles.d"
-FILES_${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/*.la"
+FILES_${PN}-dev += "${libexecdir}/${BPN}/lib*${SOLIBSDEV} ${libexecdir}/${BPN}/*.la \
+ ${libexecdir}/lib*${SOLIBSDEV} ${libexecdir}/*.la"