aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2018e.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-05-04 10:05:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-07 21:31:15 +0000
commit46bbf84f441c65f910558649c7ed2350b023cbf9 (patch)
treeb7a40dc12942758c87daefa06144843fc730a327 /meta/recipes-extended/tzcode/tzcode-native_2018e.bb
parent1019edfded5ae323d51606f933eb6177d4d49ee2 (diff)
downloadopenembedded-core-contrib-46bbf84f441c65f910558649c7ed2350b023cbf9.tar.gz
tzcode-native: updatet to 2018e
Changes to build procedure The command 'make tarballs' now also builds the tarball tzdataVERSION-rearguard.tar.gz, which is like tzdataVERSION.tar.gz except that it uses rearguard format intended for trailing-edge data parsers. Changes to data format and to code The SAVE column of Rule and Zone lines can now have an 's' or 'd' suffix, which specifies whether the adjusted time is standard time or daylight saving time. If no suffix is given, daylight saving time is used if and only if the SAVE column is nonzero; this is the longstanding behavior. Although this new feature is not used in tzdata, it could be used to specify the legal time in Namibia 1994-2017, as opposed to the popular time (see below). Changes to past time stamps From 1994 through 2017 Namibia observed DST in winter, not summer. That is, it used negative DST, as Ireland still does. This change does not affect UTC offsets; it affects only the tm_isdst flag and the abbreviation used during summer, which is now CAT, not WAST. Although (as noted by Michael Deckers) summer and winter time were both simply called "standard time" in Namibian law, in common practice winter time was considered to be DST (as noted by Stephen Colebourne). The full effect of this change is only in vanguard format; in rearguard and main format, the tm_isdst flag is still zero in winter and nonzero in summer. In 1946/7 Czechoslovakia also observed negative DST in winter. The full effect of this change is only in vanguard format; in rearguard and main formats, it is modeled as plain GMT without daylight saving. Also, the dates of some 1944/5 DST transitions in Czechoslovakia have been changed. (From OE-Core rev: aeb3d295581908ca9a9d8f1705f70b49b2de32e3) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2018e.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2018e.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2018e.bb b/meta/recipes-extended/tzcode/tzcode-native_2018e.bb
new file mode 100644
index 0000000000..9a4e46569a
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2018e.bb
@@ -0,0 +1,30 @@
+# note that we allow for us to use data later than our code version
+#
+SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD & BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c679c9d6b02bc2757b3eaf8f53c43fba"
+
+SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
+ http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata \
+ "
+
+UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
+
+SRC_URI[tzdata.md5sum] = "97d654f4d7253173b3eeb76a836dd65e"
+SRC_URI[tzdata.sha256sum] = "6b288e5926841a4cb490909fe822d85c36ae75538ad69baf20da9628b63b692e"
+SRC_URI[tzcode.md5sum] = "c4d7df0fff7ba5588b32c5f27e2caf97"
+SRC_URI[tzcode.sha256sum] = "ca340cf20e80b699d6e5c49b4ba47361b3aa681f06f38a0c88a8e8308c00ebce"
+
+S = "${WORKDIR}"
+
+inherit native
+
+EXTRA_OEMAKE += "cc='${CC}'"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}