aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzdata
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-08-29 15:09:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-02 05:52:07 -0700
commit8dd8f56f997bc2cc072270edbff44a52359ee728 (patch)
tree371ade34ac879bb8df60011fd42106eefc7d3eff /meta/recipes-extended/tzdata
parent5b1fbbebb987a78c7e3261ed53ebda5597dc0b42 (diff)
downloadopenembedded-core-contrib-8dd8f56f997bc2cc072270edbff44a52359ee728.tar.gz
tzdata: install /etc/localtime alongside /etc/timezone
Lots of code (such a GLib) expects this to exist and link to the current timezone definition. /etc/localtime is a symlink instead of a copy of hard link to make it obvious what timezone data it's pointing at. For systems with /etc on a separate filesystem to /usr this will result in a dangling symlink until /usr is mounted, but as this is early boot the assumption is that anything checking it will handle that case and fallback to UTC. (From OE-Core rev: efe305c275f288e248655f3a8b266f86c9893f73) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzdata')
-rw-r--r--meta/recipes-extended/tzdata/tzdata_2012d.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/tzdata/tzdata_2012d.bb b/meta/recipes-extended/tzdata/tzdata_2012d.bb
index 31e1266280..974110172f 100644
--- a/meta/recipes-extended/tzdata/tzdata_2012d.bb
+++ b/meta/recipes-extended/tzdata/tzdata_2012d.bb
@@ -5,7 +5,7 @@ LICENSE = "PD"
LIC_FILES_CHKSUM = "file://asia;beginline=2;endline=3;md5=06468c0e84ef4d4c97045a4a29b08234"
DEPENDS = "tzcode-native"
-PR = "r1"
+PR = "r2"
inherit allarch
@@ -49,6 +49,7 @@ do_install () {
# Install default timezone
install -d ${D}${sysconfdir}
echo ${DEFAULT_TIMEZONE} > ${D}${sysconfdir}/timezone
+ ln -s ${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ${D}${sysconfdir}/localtime
chown -R root:root ${D}
}