summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/watchdog
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-21 14:19:26 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-21 17:04:56 +0000
commit0ecfe4fd7d89252a7db6c9361fb5674cb098796d (patch)
tree7beedc615d46247773a9d170c1866b11a44a53ce /meta/recipes-extended/watchdog
parent3d27366f17e597380fee738f14f119d880a77985 (diff)
downloadopenembedded-core-contrib-0ecfe4fd7d89252a7db6c9361fb5674cb098796d.tar.gz
watchdog: Fix case where ${B} != ${S}
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/watchdog')
-rw-r--r--meta/recipes-extended/watchdog/files/fixsepbuild.patch27
-rw-r--r--meta/recipes-extended/watchdog/watchdog_5.13.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/watchdog/files/fixsepbuild.patch b/meta/recipes-extended/watchdog/files/fixsepbuild.patch
new file mode 100644
index 0000000000..2fad3a112f
--- /dev/null
+++ b/meta/recipes-extended/watchdog/files/fixsepbuild.patch
@@ -0,0 +1,27 @@
+Fix out of tree build support:
+
+| installing /etc/watchdog.conf
+| /bin/mkdir -p '/media/build1/poky/build/tmp/work/i586-poky-linux/watchdog/5.13-r0/image/usr/share/man/man5'
+| /bin/mkdir -p '/media/build1/poky/build/tmp/work/i586-poky-linux/watchdog/5.13-r0/image/usr/share/man/man8'
+| /usr/bin/install -c -m 644 /media/build1/poky/build/tmp/work/i586-poky-linux/watchdog/5.13-r0/watchdog-5.13/watchdog.conf.5 '/media/build1/poky/build/tmp/work/i586-poky-linux/watchdog/5.13-r0/image/usr/share/man/man5'
+| /usr/bin/install -c -m 644 /media/build1/poky/build/tmp/work/i586-poky-linux/watchdog/5.13-r0/watchdog-5.13/watchdog.8 /media/build1/poky/build/tmp/work/i586-poky-linux/watchdog/5.13-r0/watchdog-5.13/wd_keepalive.8 /media/build1/poky/build/tmp/work/i586-poky-linux/watchdog/5.13-r0/watchdog-5.13/wd_identify.8 '/media/build1/poky/build/tmp/work/i586-poky-linux/watchdog/5.13-r0/image/usr/share/man/man8'
+| /usr/bin/install: cannot stat `watchdog.conf': No such file or directory
+| make[2]: *** [install-etc-local] Error 1
+
+Upstream-Status: Pending
+
+RP 2013/03/21
+
+Index: watchdog-5.13/Makefile.am
+===================================================================
+--- watchdog-5.13.orig/Makefile.am 2013-02-01 11:15:44.000000000 +0000
++++ watchdog-5.13/Makefile.am 2013-03-21 11:59:35.637139031 +0000
+@@ -16,7 +16,7 @@
+ else \
+ echo "installing $(CONFIG_FILENAME)"; \
+ $(mkinstalldirs) `dirname $(DESTDIR)$(CONFIG_FILENAME)`; \
+- $(INSTALL_DATA) watchdog.conf $(DESTDIR)$(CONFIG_FILENAME); \
++ $(INSTALL_DATA) $(srcdir)/watchdog.conf $(DESTDIR)$(CONFIG_FILENAME); \
+ fi
+
+ install-data-local: install-etc-local
diff --git a/meta/recipes-extended/watchdog/watchdog_5.13.bb b/meta/recipes-extended/watchdog/watchdog_5.13.bb
index 610e4735bb..b9e29d22fc 100644
--- a/meta/recipes-extended/watchdog/watchdog_5.13.bb
+++ b/meta/recipes-extended/watchdog/watchdog_5.13.bb
@@ -9,6 +9,7 @@ LICENSE = "GPL-2.0+"
LIC_FILES_CHKSUM = "file://COPYING;md5=ecc0551bf54ad97f6b541720f84d6569"
SRC_URI = "${SOURCEFORGE_MIRROR}/watchdog/watchdog-${PV}.tar.gz \
+ file://fixsepbuild.patch \
file://fix-ping-failure.patch"
SRC_URI[md5sum] = "153455f008f1cf8f65f6ad9586a21ff1"
SRC_URI[sha256sum] = "141e0faf3ee4d8187a6ff4e00b18ef7b7a4ce432a2d4c8a6e6fdc62507fc6eb0"