aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorJian Liu <jian.liu@windriver.com>2014-11-21 17:17:13 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-03 12:22:41 +0000
commit078fedcc0b7d50e7001c587968319f1b45b3c1ba (patch)
tree37acb0ea9978fd72b9b17f3da8d1564162ccd6d9 /meta/recipes-extended
parenta265af666a80298ccca0eb80d6f15ca3d4be8b57 (diff)
downloadopenembedded-core-contrib-078fedcc0b7d50e7001c587968319f1b45b3c1ba.tar.gz
libpam: avoid overwritting editable files during package updating
Use CONFFILES to mark editable files as such, /etc/pam.d/common-session /etc/pam.d/common-auth /etc/pam.d/common-password /etc/pam.d/common-session-noninteractive /etc/pam.d/common-account If there is no %config micro before the file name in the spec file, this file will be overwritten after updating package. This will make our settings lost. Signed-off-by: Jian Liu <jian.liu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.6.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.6.bb b/meta/recipes-extended/pam/libpam_1.1.6.bb
index 3b6d5144f9..b3b39da864 100644
--- a/meta/recipes-extended/pam/libpam_1.1.6.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.6.bb
@@ -163,3 +163,9 @@ python do_pam_sanity () {
addtask pam_sanity before do_configure
BBCLASSEXTEND = "nativesdk native"
+
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-session"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-auth"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-password"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-session-noninteractive"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-account"