summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2020-03-27 10:31:56 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-29 20:03:31 +0100
commit3130f43c51fb9b2aed9bb7805a820ea90e68276a (patch)
tree41b47cd99046c4201a4f68ff7fb2b8e5335e93e3 /meta/recipes-extended
parent841573cea6d06dcba45227a8126153b0629b1b0c (diff)
downloadopenembedded-core-contrib-3130f43c51fb9b2aed9bb7805a820ea90e68276a.tar.gz
libpam: Add userdb packageconfig
Add userdb packageconfig to control the building of the pam_userdb.so module. This depends on dbm support being compiled in for the berkley db package. Also, remove "--with-db-uniquename=_pam" from EXTRA_OECONF. It makes the checks for libdb fail because it searches for the wrong symbols in libdb (and libdb was not configured with --with-uniquename=_pam option). db.do_configure: checking if --with-uniquename=NAME option specified... no libpam.do_configure: checking for db_create_pam... no checking for db_create... no checking for dbm_store_pam... no checking for dbm_store... no checking for dbm_store in -lndbm... no Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/pam/libpam_1.3.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.3.1.bb b/meta/recipes-extended/pam/libpam_1.3.1.bb
index ac8694ec26..bc72afe6ad 100644
--- a/meta/recipes-extended/pam/libpam_1.3.1.bb
+++ b/meta/recipes-extended/pam/libpam_1.3.1.bb
@@ -35,8 +35,7 @@ SRC_URI_append_libc-musl = " file://0001-Add-support-for-defining-missing-funcit
DEPENDS = "bison-native flex flex-native cracklib libxml2-native virtual/crypt"
-EXTRA_OECONF = "--with-db-uniquename=_pam \
- --includedir=${includedir}/security \
+EXTRA_OECONF = "--includedir=${includedir}/security \
--libdir=${base_libdir} \
--disable-nis \
--disable-regenerate-docu \
@@ -48,7 +47,9 @@ S = "${WORKDIR}/Linux-PAM-${PV}"
inherit autotools gettext pkgconfig
+PACKAGECONFIG ??= ""
PACKAGECONFIG[audit] = "--enable-audit,--disable-audit,audit,"
+PACKAGECONFIG[userdb] = "--enable-db=db,--enable-db=no,db,"
PACKAGES += "${PN}-runtime ${PN}-xtests"
FILES_${PN} = "${base_libdir}/lib*${SOLIBS}"