summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorJoshua Lock <joshua.lock@collabora.co.uk>2015-12-01 21:41:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-08 10:20:07 +0000
commitbb6a34a6c70206e46011e6d946f47a9acba7371d (patch)
tree14b50250084c551b0db2a994c0651563db193f36 /meta/recipes-extended
parent9950c08341a2950521f18a1bf4593e84dfab864b (diff)
downloadopenembedded-core-contrib-bb6a34a6c70206e46011e6d946f47a9acba7371d.tar.gz
cracklib: fix for base_libdir == libdir
Don't try and move the python packages from base_libdir to libdir if they are the same location. Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/cracklib/cracklib_2.9.5.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta/recipes-extended/cracklib/cracklib_2.9.5.bb b/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
index c0ffe33160..23f259c6a6 100644
--- a/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
+++ b/meta/recipes-extended/cracklib/cracklib_2.9.5.bb
@@ -28,10 +28,13 @@ do_install_append() {
src_dir="${D}${base_libdir}/${PYTHON_DIR}/site-packages"
rm -f $src_dir/*.pyo
rm -f $src_dir/test_cracklib.py
- # Move python files from ${base_libdir} to ${libdir} since used --libdir=${base_libdir}
- install -d -m 0755 ${D}${PYTHON_SITEPACKAGES_DIR}/
- mv $src_dir/* ${D}${PYTHON_SITEPACKAGES_DIR}
- rm -fr ${D}${base_libdir}/${PYTHON_DIR}
+
+ if [ "${base_libdir}" != "${libdir}" ] ; then
+ # Move python files from ${base_libdir} to ${libdir} since used --libdir=${base_libdir}
+ install -d -m 0755 ${D}${PYTHON_SITEPACKAGES_DIR}/
+ mv $src_dir/* ${D}${PYTHON_SITEPACKAGES_DIR}
+ rm -fr ${D}${base_libdir}/${PYTHON_DIR}
+ fi
}
BBCLASSEXTEND = "native nativesdk"