aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-09-17 00:39:35 -0700
committerRobert Yang <liezhi.yang@windriver.com>2015-09-17 19:31:46 -0700
commit7fab77e612b616c57fa474334a2415477828fe58 (patch)
treee13f1c63d547853c7c1e6b223a9a777b8639af05 /meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
parentf0189829498e30231d826c9f55aad73e622d076e (diff)
downloadopenembedded-core-contrib-rbt/low_version.tar.gz
meta: fix build with gettext 0.16.1rbt/low_version
The gettext 0.16.1 doesn't install any m4 files to sysroot, please see the following commit: commit 9e10db5bdfe77c0ef2aff2f1cf89958b62c294a1 Author: Christopher Larson <kergoth@gmail.com> Date: Mon Mar 17 18:10:54 2014 +0000 gettext-0.16.1: kill target m4 macros from sysroot This is aim for using gettext-native's macros(gettext-native-0.19.4), but when we set: PREFERRED_VERSION_gettext = "0.16.1" And build the recipes like pcmanfm, we would get errors when do_configure: configure:5164: error: possibly undefined macro: AM_NLS This is because autotools_copy_aclocals doesn't copy the native macros for target unless they're direct dependencies. inherit gettext will fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb')
-rw-r--r--meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb b/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
index c30454cab5..140589bac9 100644
--- a/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
+++ b/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
@@ -31,7 +31,7 @@ CFLAGS_prepend = "-DHAVE_ANIMATION "
RDEPENDS_${PN}-dev = ""
-inherit gnomebase
+inherit gnomebase gettext
GNOME_COMPRESS_TYPE="bz2"
python populate_packages_prepend() {