aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libmatchbox
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-12-10 12:13:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-10 14:13:01 +0000
commit8505f0fa48cc79d51616b923c6e2c778c4b46a44 (patch)
treeeb26ecc4dbb4aee538db93d4c5e5f824ae7ff6c4 /meta/recipes-graphics/libmatchbox
parent1f17598031059f498e8681cd09c5b0832622d3ac (diff)
downloadopenembedded-core-contrib-8505f0fa48cc79d51616b923c6e2c778c4b46a44.tar.gz
libmatchbox: use PACKAGECONFIG
Use PACKAGECONFIG to offer some flexibility to the libmatchbox configuration, and remove two spurious build dependencies (expat and libstartup-notification). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libmatchbox')
-rw-r--r--meta/recipes-graphics/libmatchbox/libmatchbox_1.11.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-graphics/libmatchbox/libmatchbox_1.11.bb b/meta/recipes-graphics/libmatchbox/libmatchbox_1.11.bb
index 118c808cfc..e2e971ecc7 100644
--- a/meta/recipes-graphics/libmatchbox/libmatchbox_1.11.bb
+++ b/meta/recipes-graphics/libmatchbox/libmatchbox_1.11.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
file://libmb/mbexp.c;endline=20;md5=28c0aef3b23e308464f5dae6a11b0d2f \
file://libmb/mbdotdesktop.c;endline=21;md5=5a287156b3207e851c1d68d09c439b51"
-DEPENDS = "virtual/libx11 libxext expat libxft jpeg libpng zlib libxsettings-client startup-notification"
+DEPENDS = "virtual/libx11 libxext"
SRC_URI = "http://downloads.yoctoproject.org/releases/matchbox/${BPN}/${PV}/${BPN}-${PV}.tar.bz2 \
file://libpng.patch"
@@ -18,4 +18,9 @@ SRC_URI[sha256sum] = "254cab52e304a3512c8df4be59d690cf3921bbb68a28ede7fe26b93534
inherit autotools pkgconfig
-EXTRA_OECONF = "--enable-jpeg --enable-xsettings"
+PACKAGECONFIG ??= "jpeg png xft xsettings"
+PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
+PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
+PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
+PACKAGECONFIG[xft] = "--enable-xft,--disable-xft,libxft"
+PACKAGECONFIG[xsettings] = "--enable-xsettings,--disable-xsettings,libxsettings-client"